exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New

Gentoo Linux Security Advisory 201701-33

Gentoo Linux Security Advisory 201701-33
Posted Jan 13, 2017
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory 201701-33 - Multiple vulnerabilities have been found in PostgreSQL, the worst of which could result in execution of arbitrary code or privilege escalation. Versions less than 9.5.4 are affected.

tags | advisory, arbitrary, vulnerability
systems | linux, gentoo
advisories | CVE-2015-5288, CVE-2015-5289, CVE-2016-0766, CVE-2016-0773, CVE-2016-5423, CVE-2016-5424
SHA-256 | 5c1835ce9d97c2296528f8ac7307f5177d1c964c2ef3bec50562a53e37dcd826

Gentoo Linux Security Advisory 201701-33

Change Mirror Download

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201701-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PostgreSQL: Multiple vulnerabilities
Date: January 12, 2017
Bugs: #562586, #574456, #602130
ID: 201701-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL, the worst of
which could result in execution of arbitrary code or privilege
escalation.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql < 9.5.4 >= 9.5.4:9.5
>= 9.4.9:9.4
>= 9.3.14:9.3
>= 9.2.18:9.2
>= 9.1.23:9.1

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of Service condition, or
escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.5.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.4:9.5"

All PostgreSQL 9.4.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">dev-db/postgresql-9.4.9:9.4"

All PostgreSQL 9.3.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">dev-db/postgresql-9.3.14:9.3"

All PostgreSQL 9.2.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">dev-db/postgresql-9.2.18:9.2"

All PostgreSQL 9.1.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">dev-db/postgresql-9.1.23:9.1"

References
==========

[ 1 ] CVE-2015-5288
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5288
[ 2 ] CVE-2015-5289
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5289
[ 3 ] CVE-2016-0766
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0766
[ 4 ] CVE-2016-0773
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0773
[ 5 ] CVE-2016-5423
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-5423
[ 6 ] CVE-2016-5424
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-5424

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201701-33

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


Login or Register to add favorites

File Archive:

November 2022

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Nov 1st
    16 Files
  • 2
    Nov 2nd
    17 Files
  • 3
    Nov 3rd
    17 Files
  • 4
    Nov 4th
    11 Files
  • 5
    Nov 5th
    0 Files
  • 6
    Nov 6th
    0 Files
  • 7
    Nov 7th
    3 Files
  • 8
    Nov 8th
    59 Files
  • 9
    Nov 9th
    12 Files
  • 10
    Nov 10th
    6 Files
  • 11
    Nov 11th
    11 Files
  • 12
    Nov 12th
    1 Files
  • 13
    Nov 13th
    0 Files
  • 14
    Nov 14th
    9 Files
  • 15
    Nov 15th
    33 Files
  • 16
    Nov 16th
    53 Files
  • 17
    Nov 17th
    11 Files
  • 18
    Nov 18th
    14 Files
  • 19
    Nov 19th
    0 Files
  • 20
    Nov 20th
    0 Files
  • 21
    Nov 21st
    26 Files
  • 22
    Nov 22nd
    22 Files
  • 23
    Nov 23rd
    10 Files
  • 24
    Nov 24th
    9 Files
  • 25
    Nov 25th
    11 Files
  • 26
    Nov 26th
    0 Files
  • 27
    Nov 27th
    0 Files
  • 28
    Nov 28th
    20 Files
  • 29
    Nov 29th
    0 Files
  • 30
    Nov 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close