what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New
Showing 1 - 4 of 4 RSS Feed

CVE-2009-4214

Status Candidate

Overview

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Related Files

Debian Security Advisory 2301-2
Posted Jan 24, 2012
Authored by Debian | Site debian.org

Debian Linux Security Advisory 2301-2 - It was discovered that the last security update for Ruby on Rails, DSA-2301-1, introduced a regression in the libactionpack-ruby package.

tags | advisory, ruby
systems | linux, debian
advisories | CVE-2011-2930, CVE-2011-2931, CVE-2011-3186, CVE-2009-4214
SHA-256 | ef3167ca6e6bc40b5f6687882b1d2cacc94bbf6b0ebc1f2bf961163c8ef91d9e
Debian Security Advisory 2301-1
Posted Sep 7, 2011
Authored by Debian | Site debian.org

Debian Linux Security Advisory 2301-1 - Several vulnerabilities have been discovered in Rails, the Ruby web application framework.

tags | advisory, web, vulnerability, ruby
systems | linux, debian
advisories | CVE-2011-2930, CVE-2011-2931, CVE-2011-3186, CVE-2009-4214
SHA-256 | b334f5cf62cfb6b04e216ea9085ae454d58013cd546c3daa75b90f34636c3ee0
Debian Security Advisory 2260-1
Posted Jun 14, 2011
Authored by Debian | Site debian.org

Debian Linux Security Advisory 2260-1 - Two vulnerabilities were discovered in Ruby on Rails, a web application framework.

tags | advisory, web, vulnerability, ruby
systems | linux, debian
advisories | CVE-2009-3086, CVE-2009-4214
SHA-256 | 393e0d36ccbed8ff1c5830a32f65306af4d797f52757615b801f2a287e96475b
Gentoo Linux Security Advisory 200912-2
Posted Dec 21, 2009
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory 200912-2 - Multiple vulnerabilities have been discovered in Rails, the worst of which leading to the execution of arbitrary SQL statements. Versions less than 2.2.2 are affected.

tags | advisory, arbitrary, vulnerability
systems | linux, gentoo
advisories | CVE-2007-5380, CVE-2007-6077, CVE-2008-4094, CVE-2008-7248, CVE-2009-2422, CVE-2009-3009, CVE-2009-3086, CVE-2009-4214
SHA-256 | 16d8e364cfb92aed20ead8b90f7ddfb138996017dcb068bdfb6e381ed4b6eee8
Page 1 of 1
Back1Next

File Archive:

November 2022

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Nov 1st
    16 Files
  • 2
    Nov 2nd
    17 Files
  • 3
    Nov 3rd
    17 Files
  • 4
    Nov 4th
    11 Files
  • 5
    Nov 5th
    0 Files
  • 6
    Nov 6th
    0 Files
  • 7
    Nov 7th
    3 Files
  • 8
    Nov 8th
    59 Files
  • 9
    Nov 9th
    12 Files
  • 10
    Nov 10th
    6 Files
  • 11
    Nov 11th
    11 Files
  • 12
    Nov 12th
    1 Files
  • 13
    Nov 13th
    0 Files
  • 14
    Nov 14th
    9 Files
  • 15
    Nov 15th
    33 Files
  • 16
    Nov 16th
    53 Files
  • 17
    Nov 17th
    11 Files
  • 18
    Nov 18th
    14 Files
  • 19
    Nov 19th
    0 Files
  • 20
    Nov 20th
    0 Files
  • 21
    Nov 21st
    26 Files
  • 22
    Nov 22nd
    22 Files
  • 23
    Nov 23rd
    10 Files
  • 24
    Nov 24th
    9 Files
  • 25
    Nov 25th
    11 Files
  • 26
    Nov 26th
    0 Files
  • 27
    Nov 27th
    0 Files
  • 28
    Nov 28th
    0 Files
  • 29
    Nov 29th
    0 Files
  • 30
    Nov 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close