exploit the possibilities
Showing 1 - 5 of 5 RSS Feed

CVE-2005-2337

Status Candidate

Overview

Ruby 1.6.x up to 1.6.8, 1.8.x up to 1.8.2, and 1.9.0 development up to 2005-09-01 allows attackers to bypass safe level and taint flag protections and execute disallowed code when Ruby processes a program through standard input (stdin).

Related Files

Debian Linux Security Advisory 864-1
Posted Oct 13, 2005
Authored by Debian | Site security.debian.org

Debian Security Advisory DSA 864-1 - Yutaka Oiwa discovered a bug in Ruby, the interpreter for the object-oriented scripting language, that can cause illegal program code to bypass the safe level and taint flag protections check and be executed.

tags | advisory, ruby
systems | linux, debian
advisories | CVE-2005-2337
MD5 | 4be4e7e0348db4dd404bf820e7497a4f
Debian Linux Security Advisory 862-1
Posted Oct 12, 2005
Authored by Debian | Site security.debian.org

Debian Security Advisory DSA 862-1 - Yutaka Oiwa discovered a bug in Ruby, the interpreter for the object-oriented scripting language, that can cause illegal program code to bypass the safe level and taint flag protections check and be executed.

tags | advisory, ruby
systems | linux, debian
advisories | CVE-2005-2337
MD5 | 86c68dca2a5004361bba59fdf4fe4210
Debian Linux Security Advisory 860-1
Posted Oct 12, 2005
Authored by Debian | Site security.debian.org

Debian Security Advisory DSA 860-1 - Yutaka Oiwa discovered a bug in Ruby, the interpreter for the object-oriented scripting language, that can cause illegal program code to bypass the safe level and taint flag protections check and be executed.

tags | advisory, ruby
systems | linux, debian
advisories | CVE-2005-2337
MD5 | 37993bea0fedd2bd4f70306316f18570
Ubuntu Security Notice 195-1
Posted Oct 11, 2005
Authored by Ubuntu | Site security.ubuntu.com

Ubuntu Security Notice USN-195-1 - The object oriented scripting language Ruby supports safely executing untrusted code with two mechanisms: safe level and taint flag on objects. Dr. Yutaka Oiwa discovered a vulnerability that allows Ruby methods to bypass these mechanisms. In systems which use this feature, this could be exploited to execute Ruby code beyond the restrictions specified in each safe level.

tags | advisory, ruby
systems | linux, ubuntu
advisories | CVE-2005-2337
MD5 | 4bce6b11946131a1643b1978a4240cc4
Gentoo Linux Security Advisory 200510-5
Posted Oct 7, 2005
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory GLSA 200510-05 - Dr. Yutaka Oiwa discovered that Ruby fails to properly enforce safe level protections. Versions less than 1.8.3 are affected.

tags | advisory, ruby
systems | linux, gentoo
advisories | CVE-2005-2337
MD5 | 88ac6fd53184ba4a6e11156ba4a244e9
Page 1 of 1
Back1Next

File Archive:

June 2020

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Jun 1st
    10 Files
  • 2
    Jun 2nd
    16 Files
  • 3
    Jun 3rd
    15 Files
  • 4
    Jun 4th
    25 Files
  • 5
    Jun 5th
    8 Files
  • 6
    Jun 6th
    0 Files
  • 7
    Jun 7th
    0 Files
  • 8
    Jun 8th
    0 Files
  • 9
    Jun 9th
    0 Files
  • 10
    Jun 10th
    0 Files
  • 11
    Jun 11th
    0 Files
  • 12
    Jun 12th
    0 Files
  • 13
    Jun 13th
    0 Files
  • 14
    Jun 14th
    0 Files
  • 15
    Jun 15th
    0 Files
  • 16
    Jun 16th
    0 Files
  • 17
    Jun 17th
    0 Files
  • 18
    Jun 18th
    0 Files
  • 19
    Jun 19th
    0 Files
  • 20
    Jun 20th
    0 Files
  • 21
    Jun 21st
    0 Files
  • 22
    Jun 22nd
    0 Files
  • 23
    Jun 23rd
    0 Files
  • 24
    Jun 24th
    0 Files
  • 25
    Jun 25th
    0 Files
  • 26
    Jun 26th
    0 Files
  • 27
    Jun 27th
    0 Files
  • 28
    Jun 28th
    0 Files
  • 29
    Jun 29th
    0 Files
  • 30
    Jun 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2020 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close