exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New

Gentoo Linux Security Advisory 201601-02

Gentoo Linux Security Advisory 201601-02
Posted Jan 27, 2016
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory 201601-2 - Multiple vulnerabilities have been found in WebKitGTK+, allowing remote attackers to execute arbitrary code or cause a Denial of Service condition. Versions less than 2.4.9 are affected.

tags | advisory, remote, denial of service, arbitrary, vulnerability
systems | linux, gentoo
advisories | CVE-2014-1344, CVE-2014-1384, CVE-2014-1385, CVE-2014-1386, CVE-2014-1387, CVE-2014-1388, CVE-2014-1389, CVE-2014-1390
SHA-256 | f3a5025bfb0304bda37a58157d49dc12fa3b3ccb0643fbfd5c1f28f0eba464cb

Gentoo Linux Security Advisory 201601-02

Change Mirror Download
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201601-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: WebKitGTK+: Multiple vulnerabilities
Date: January 26, 2016
Bugs: #536234
ID: 201601-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in WebKitGTK+, allowing remote
attackers to execute arbitrary code or cause a Denial of Service
condition.

Background
==========

WebKitGTK+ is a full-featured port of the WebKit rendering engine.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/webkit-gtk < 2.4.9 >= 2.4.9

Description
===========

Multiple vulnerabilities have been discovered in WebKitGTK+. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attack can use multiple vectors to execute arbitrary code or
cause a denial of service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All WebKitGTK+ 3 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.4.9:3"

All WebKitGTK+ 2 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=net-libs/webkit-gtk-2.4.9-r200:2"

References
==========

[ 1 ] CVE-2014-1344
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1344
[ 2 ] CVE-2014-1384
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1384
[ 3 ] CVE-2014-1385
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1385
[ 4 ] CVE-2014-1386
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1386
[ 5 ] CVE-2014-1387
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1387
[ 6 ] CVE-2014-1388
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1388
[ 7 ] CVE-2014-1389
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1389
[ 8 ] CVE-2014-1390
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1390

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201601-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2016 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Login or Register to add favorites

File Archive:

November 2022

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Nov 1st
    16 Files
  • 2
    Nov 2nd
    17 Files
  • 3
    Nov 3rd
    17 Files
  • 4
    Nov 4th
    11 Files
  • 5
    Nov 5th
    0 Files
  • 6
    Nov 6th
    0 Files
  • 7
    Nov 7th
    3 Files
  • 8
    Nov 8th
    59 Files
  • 9
    Nov 9th
    12 Files
  • 10
    Nov 10th
    6 Files
  • 11
    Nov 11th
    11 Files
  • 12
    Nov 12th
    1 Files
  • 13
    Nov 13th
    0 Files
  • 14
    Nov 14th
    9 Files
  • 15
    Nov 15th
    33 Files
  • 16
    Nov 16th
    53 Files
  • 17
    Nov 17th
    11 Files
  • 18
    Nov 18th
    14 Files
  • 19
    Nov 19th
    0 Files
  • 20
    Nov 20th
    0 Files
  • 21
    Nov 21st
    26 Files
  • 22
    Nov 22nd
    22 Files
  • 23
    Nov 23rd
    10 Files
  • 24
    Nov 24th
    9 Files
  • 25
    Nov 25th
    11 Files
  • 26
    Nov 26th
    0 Files
  • 27
    Nov 27th
    0 Files
  • 28
    Nov 28th
    20 Files
  • 29
    Nov 29th
    9 Files
  • 30
    Nov 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close