what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New

Astaro Security Gateway 8.1 Cross Site Scripting

Astaro Security Gateway 8.1 Cross Site Scripting
Posted Jan 6, 2012
Authored by Vulnerability Laboratory | Site vulnerability-lab.com

Astaro Security Gateway version 8.1 suffers from a cross site scripting vulnerability.

tags | exploit, xss
SHA-256 | 3b5c95c7ca015df34dedf436f15b98986c06ef80d2f532b960baca050c4707ae

Astaro Security Gateway 8.1 Cross Site Scripting

Change Mirror Download
Title:
======
Astaro Security Gateway v8.1 - Input Validation Vulnerability


Date:
=====
2011-12-27


References:
===========
http://www.vulnerability-lab.com/get_content.php?id=193


VL-ID:
=====
193


Introduction:
=============
Das Astaro Security Gateway 8.101 wurde speziell für den Schutz großer Unternehmen konzipiert.
Basierend auf hochwertigen Intel-kompatiblen Serversystemen, einschließlich Dual IntelTM Xeon-Multi-Core-Prozessoren
sowie redundanten Highspeed-Festplatten, bietet es selbst für die herausforderndsten Umgebungen optimale Performance
und Zuverlässigkeit. Dieser Abschnitt beschreibt detailliert die verfügbaren Sicherheitsanwendungen, technischen
Einzelheiten und Einsatzszenarien.

(Copy of the Vendor Homepage: https://www.astaro.com/de-de/produkte/hardware-appliance/astaro-security-gateway-625)


Abstract:
=========
Vulnerability-Lab Team discovered a persistent Cross Site Scripting issue on Astaro Security Gateway.


Report-Timeline:
================
2011-12-27: Public or Non-Public Disclosure


Status:
========
Published


Affected Products:
==================
Astaro Security Gateway v8.1


Exploitation-Technique:
=======================
Remote


Severity:
=========
Medium


Details:
========
A persistent cross site scripting vulnerability is detected on Astaro Security Gateway v8.101.
The vulnerability allows an privileged user account to implement malicious persistent script code.
The bug is located in the preview function of the certificate delete popup box.

Vulnerable Module(s):
[+] Certificate - Delete Preview Popup Box

Pictures:
../1.png


Proof of Concept:
=================
The vulnerability can be exploited by remote attackers or privileged restricted user accounts.
For demonstration or reproduce ...

Site-2-Site VPN - Certificate Management Preview

<div style="left: 300px; top: 220px; z-index: 2000; visibility: visible;" class="iPopUp" id="iPopup_2"><div

class="iPopUpTitle">Please confirm:</div><div class="iPopUpText"><p>​​​​​Are you sure that you want to delete the X509 certificate

with private key object '>"<INCLUDED PERSISTENT SCRIPTCODE HERE!!!">'?</p></iframe></p></div><table border="0"

cellpadding="0" cellspacing="0"><tbody><tr><td style="padding: 2px;"><div id="btnDefault_iPopup_2" class="button" style="width:

auto; cursor: pointer; color: black; font-weight: bold;"><div class="button_left"></div><div class="button_center" style="width:

auto;"><span style="font-weight: normal;">OK</span></div><div class="button_right"></div></div></td>​​​​​<td style="padding:

2px;"><div class="button" style="width: auto; cursor: pointer; color: black;"><div class="button_left"></div><div

class="button_center" style="width: auto;"><span style="font-weight: normal;">Cancel</span></div><div

class="button_right"></div></div></td></tr></tbody></table></div>

../index.dat


Risk:
=====
The security risk of the persistent vulnerability is estimated as medium.


Credits:
========
Vulnerability Research Laboratory


Disclaimer:
===========
The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all warranties,
either expressed or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-
Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss of business
profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such damages. Some
states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation
may not apply. Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability-
Lab. Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of
other media, are reserved by Vulnerability-Lab or its suppliers.

Copyright © 2011|Vulnerability-Lab




--
Website: www.vulnerability-lab.com ; vuln-lab.com or vuln-db.com
Contact: admin@vulnerability-lab.com or support@vulnerability-lab.com

Login or Register to add favorites

File Archive:

April 2024

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Apr 1st
    10 Files
  • 2
    Apr 2nd
    26 Files
  • 3
    Apr 3rd
    40 Files
  • 4
    Apr 4th
    6 Files
  • 5
    Apr 5th
    26 Files
  • 6
    Apr 6th
    0 Files
  • 7
    Apr 7th
    0 Files
  • 8
    Apr 8th
    22 Files
  • 9
    Apr 9th
    14 Files
  • 10
    Apr 10th
    10 Files
  • 11
    Apr 11th
    13 Files
  • 12
    Apr 12th
    14 Files
  • 13
    Apr 13th
    0 Files
  • 14
    Apr 14th
    0 Files
  • 15
    Apr 15th
    30 Files
  • 16
    Apr 16th
    10 Files
  • 17
    Apr 17th
    22 Files
  • 18
    Apr 18th
    0 Files
  • 19
    Apr 19th
    0 Files
  • 20
    Apr 20th
    0 Files
  • 21
    Apr 21st
    0 Files
  • 22
    Apr 22nd
    0 Files
  • 23
    Apr 23rd
    0 Files
  • 24
    Apr 24th
    0 Files
  • 25
    Apr 25th
    0 Files
  • 26
    Apr 26th
    0 Files
  • 27
    Apr 27th
    0 Files
  • 28
    Apr 28th
    0 Files
  • 29
    Apr 29th
    0 Files
  • 30
    Apr 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close