what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New

Adium 1.4.2 Cross Site Scripting

Adium 1.4.2 Cross Site Scripting
Posted Aug 2, 2011
Authored by noptrix | Site nullsecurity.net

Adium versions 1.4.2 and below suffer from a cross site scripting vulnerability.

tags | exploit, xss
SHA-256 | 0bc772b94e276215873af7b4736035264927370480ad0412051e68b6bc0c92b5

Adium 1.4.2 Cross Site Scripting

Change Mirror Download
+-----------------------------------------------------------------------------+
| noptrix.net - Public Security Advisory |
+-----------------------------------------------------------------------------+


Date:
-----
08/02/2011

Vendor:
-------
Adium - http://www.adium.im/

Affected Software:
------------------
Software: Adium
Version: <= 1.4.2

Affected Platforms:
-------------------
Mac OS X (10.6.8, 10.6.7, maybe also other...)

Vulnerability Class:
--------------------
HTML/Javascript-Injection / Cross-Site Scripting

Description:
------------
Adium suffers from a persistent HTML/Javascript injection / Cross-Site Scripting
vulnerability due to a lack of input validation and output sanitization of
filenames.

Proof of Concept:
-----------------
The following HTML/Javascript payload can be used as a filename to trigger the
described vulnerability:

--- SNIP ---

sh3ll$ echo "123" > \"\>\<body\>\<h1\>0x90trix\ pwns\ -\ XSS\ POWER\ \<iframe\ \src\=\"www.google.com\"\ style\=\"background-color\:\ green\".gif

--- SNIP ---

For a PoC demonstration see:
- http://www.noptrix.net/tmp/adium_inject.png
- http://www.noptrix.net/tmp/adium_inject2.png
- http://www.noptrix.net/tmp/adium_inject3.png

Impact:
-------
An attacker could for example inject HTML/Javascript code and redirect/phish any
users of Adium. With some time, creativity, fantasy and good music, an attacker
could leverage the vulnerability to increase the attack vector to the underlying
software and operating system of the victim.

Threat Level:
-------------
Medium - High

Solution:
---------
adium.im has to validate the input characters and sanitize the output.

Status:
-------
Adium hasn't fixed the issue yet.

Notes:
------
To the whole world: Funny thing: Anglophone and German media refer me as
Armenian in their Skype XSS articles, yet all the Turkish news sites insists
that I am Turkish. For the record, I am Armenian and my people have been
persecuted by Turkey for hundreds of years. Thanks.
Login or Register to add favorites

File Archive:

April 2024

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Apr 1st
    10 Files
  • 2
    Apr 2nd
    26 Files
  • 3
    Apr 3rd
    40 Files
  • 4
    Apr 4th
    6 Files
  • 5
    Apr 5th
    26 Files
  • 6
    Apr 6th
    0 Files
  • 7
    Apr 7th
    0 Files
  • 8
    Apr 8th
    22 Files
  • 9
    Apr 9th
    14 Files
  • 10
    Apr 10th
    10 Files
  • 11
    Apr 11th
    13 Files
  • 12
    Apr 12th
    14 Files
  • 13
    Apr 13th
    0 Files
  • 14
    Apr 14th
    0 Files
  • 15
    Apr 15th
    30 Files
  • 16
    Apr 16th
    10 Files
  • 17
    Apr 17th
    22 Files
  • 18
    Apr 18th
    45 Files
  • 19
    Apr 19th
    8 Files
  • 20
    Apr 20th
    0 Files
  • 21
    Apr 21st
    0 Files
  • 22
    Apr 22nd
    11 Files
  • 23
    Apr 23rd
    68 Files
  • 24
    Apr 24th
    0 Files
  • 25
    Apr 25th
    0 Files
  • 26
    Apr 26th
    0 Files
  • 27
    Apr 27th
    0 Files
  • 28
    Apr 28th
    0 Files
  • 29
    Apr 29th
    0 Files
  • 30
    Apr 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close