exploit the possibilities

Drupal Elegant Theme 7.x Cross Site Scripting

Drupal Elegant Theme 7.x Cross Site Scripting
Posted Aug 15, 2012
Authored by Greg Knaddison | Site drupal.org

Drupal Elegant Theme third party module version 7.x suffers from a cross site scripting vulnerability.

tags | advisory, xss
MD5 | 93e1dd81ddd5ebda197e62d31db8ed27

Drupal Elegant Theme 7.x Cross Site Scripting

Change Mirror Download
View online: http://drupal.org/node/1733056

* Advisory ID: DRUPAL-SA-CONTRIB-2012-128
* Project: Elegant Theme [1] (third-party module)
* Version: 7.x
* Date: 2012-August-15
* Security risk: Moderately critical [2]
* Exploitable from: Remote
* Vulnerability: Cross Site Scripting

-------- DESCRIPTION
---------------------------------------------------------

Elegant Theme is a light weight Drupal 7 theme with a modern look and feel.

The theme doesn't properly sanitize user-entered content in the 3 slide
gallery on the homepage leading to a Cross Site Scripting (XSS)
vulnerability.

This vulnerability is mitigated by the fact that an attacker would have to
have the 'administer themes' permission.

CVE: Requested

-------- VERSIONS AFFECTED
---------------------------------------------------

* Elegant Theme 7.x-1.x versions prior to 7.x-1.0.

Drupal core is not affected. If you do not use the contributed Elegant Theme
[3] module, there is nothing you need to do.

-------- SOLUTION
------------------------------------------------------------

Install the latest version:

* If you use the Elegant Theme for Drupal 7.x, upgrade to Elegant Theme
7.x-1.1 [4]

Also see the Elegant Theme [5] project page.

-------- REPORTED BY
---------------------------------------------------------

* Greg Knaddison [6] of the Drupal Security Team

-------- FIXED BY
------------------------------------------------------------

* saran.quardz [7] the module maintainer

-------- COORDINATED BY
------------------------------------------------------

* Greg Knaddison [8] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [9].

Learn more about the Drupal Security team and their policies [10], writing
secure code for Drupal [11], and securing your site [12].


[1] http://drupal.org/project/elegant_theme
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/elegant_theme
[4] http://drupal.org/node/1722880
[5] http://drupal.org/project/elegant_theme
[6] http://drupal.org/user/36762
[7] http://drupal.org/user/1031208
[8] http://drupal.org/user/36762
[9] http://drupal.org/contact
[10] http://drupal.org/security-team
[11] http://drupal.org/writing-secure-code
[12] http://drupal.org/security/secure-configuration

Login or Register to add favorites

File Archive:

November 2021

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Nov 1st
    19 Files
  • 2
    Nov 2nd
    25 Files
  • 3
    Nov 3rd
    8 Files
  • 4
    Nov 4th
    7 Files
  • 5
    Nov 5th
    24 Files
  • 6
    Nov 6th
    0 Files
  • 7
    Nov 7th
    0 Files
  • 8
    Nov 8th
    18 Files
  • 9
    Nov 9th
    9 Files
  • 10
    Nov 10th
    106 Files
  • 11
    Nov 11th
    19 Files
  • 12
    Nov 12th
    13 Files
  • 13
    Nov 13th
    0 Files
  • 14
    Nov 14th
    0 Files
  • 15
    Nov 15th
    18 Files
  • 16
    Nov 16th
    12 Files
  • 17
    Nov 17th
    15 Files
  • 18
    Nov 18th
    12 Files
  • 19
    Nov 19th
    4 Files
  • 20
    Nov 20th
    2 Files
  • 21
    Nov 21st
    0 Files
  • 22
    Nov 22nd
    22 Files
  • 23
    Nov 23rd
    14 Files
  • 24
    Nov 24th
    19 Files
  • 25
    Nov 25th
    4 Files
  • 26
    Nov 26th
    1 Files
  • 27
    Nov 27th
    4 Files
  • 28
    Nov 28th
    1 Files
  • 29
    Nov 29th
    11 Files
  • 30
    Nov 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2020 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close