what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New

Ubuntu Security Notice USN-6164-1

Ubuntu Security Notice USN-6164-1
Posted Jun 16, 2023
Authored by Ubuntu | Site security.ubuntu.com

Ubuntu Security Notice 6164-1 - Hannes Moesl discovered that c-ares incorrectly handled certain ipv6 addresses. An attacker could use this issue to cause c-ares to crash, resulting in a denial of service, or possibly execute arbitrary code. Xiang Li discovered that c-ares incorrectly handled certain UDP packets. A remote attacker could possibly use this issue to cause c-res to crash, resulting in a denial of service.

tags | advisory, remote, denial of service, arbitrary, udp
systems | linux, ubuntu
advisories | CVE-2023-31130, CVE-2023-32067
SHA-256 | 0112dec7e71722ec1f679b97f759de4ebeaead0ca6d25c4fc1e459e5fa65bb9f

Ubuntu Security Notice USN-6164-1

Change Mirror Download
==========================================================================
Ubuntu Security Notice USN-6164-1
June 14, 2023

c-ares vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in c-ares.

Software Description:
- c-ares: library for asynchronous name resolution

Details:

Hannes Moesl discovered that c-ares incorrectly handled certain ipv6
addresses. An attacker could use this issue to cause c-ares to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2023-31130)

Xiang Li discovered that c-ares incorrectly handled certain UDP packets. A
remote attacker could possibly use this issue to cause c-res to crash,
resulting in a denial of service. (CVE-2023-32067)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
libc-ares2 1.18.1-2ubuntu0.1

Ubuntu 22.10:
libc-ares2 1.18.1-1ubuntu0.22.10.2

Ubuntu 22.04 LTS:
libc-ares2 1.18.1-1ubuntu0.22.04.2

Ubuntu 20.04 LTS:
libc-ares2 1.15.0-1ubuntu0.3

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6164-1
CVE-2023-31130, CVE-2023-32067

Package Information:
https://launchpad.net/ubuntu/+source/c-ares/1.18.1-2ubuntu0.1
https://launchpad.net/ubuntu/+source/c-ares/1.18.1-1ubuntu0.22.10.2
https://launchpad.net/ubuntu/+source/c-ares/1.18.1-1ubuntu0.22.04.2
https://launchpad.net/ubuntu/+source/c-ares/1.15.0-1ubuntu0.3

Login or Register to add favorites

File Archive:

May 2024

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    May 1st
    44 Files
  • 2
    May 2nd
    5 Files
  • 3
    May 3rd
    11 Files
  • 4
    May 4th
    0 Files
  • 5
    May 5th
    0 Files
  • 6
    May 6th
    28 Files
  • 7
    May 7th
    3 Files
  • 8
    May 8th
    4 Files
  • 9
    May 9th
    54 Files
  • 10
    May 10th
    12 Files
  • 11
    May 11th
    0 Files
  • 12
    May 12th
    0 Files
  • 13
    May 13th
    17 Files
  • 14
    May 14th
    11 Files
  • 15
    May 15th
    17 Files
  • 16
    May 16th
    13 Files
  • 17
    May 17th
    22 Files
  • 18
    May 18th
    0 Files
  • 19
    May 19th
    0 Files
  • 20
    May 20th
    17 Files
  • 21
    May 21st
    18 Files
  • 22
    May 22nd
    0 Files
  • 23
    May 23rd
    0 Files
  • 24
    May 24th
    0 Files
  • 25
    May 25th
    0 Files
  • 26
    May 26th
    0 Files
  • 27
    May 27th
    0 Files
  • 28
    May 28th
    0 Files
  • 29
    May 29th
    0 Files
  • 30
    May 30th
    0 Files
  • 31
    May 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close