exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New
Showing 1 - 5 of 5 RSS Feed

CVE-2008-7159

Status Candidate

Overview

The silc_asn1_encoder function in lib/silcasn1/silcasn1_encode.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.8 allows remote attackers to overwrite a stack location and possibly execute arbitrary code via a crafted OID value, related to incorrect use of a %lu format string.

Related Files

Gentoo Linux Security Advisory 201006-7
Posted Jun 2, 2010
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory 201006-7 - Multiple vulnerabilities were discovered in SILC Toolkit and SILC Client, the worst of which allowing for execution of arbitrary code. Multiple vulnerabilities were discovered in SILC Toolkit and SILC Client. For further information please consult the CVE entries referenced below. Versions less than 1.1.10 are affected.

tags | advisory, arbitrary, vulnerability
systems | linux, gentoo
advisories | CVE-2008-7159, CVE-2008-7160, CVE-2009-3051, CVE-2009-3163
SHA-256 | 09c6f320cb1842d1cf2f553bd190328e48a36e499ce25f06245ec682f1c95c8b
Mandriva Linux Security Advisory 2009-234
Posted Dec 7, 2009
Authored by Mandriva | Site mandriva.com

Mandriva Linux Security Advisory 2009-234 - Multiple format string vulnerabilities in lib/silcclient/client_entry.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.10, and SILC Client before 1.1.8, allow remote attackers to execute arbitrary code via format string specifiers in a nickname field, related to the (1) silc_client_add_client, (2) silc_client_update_client, and (3) silc_client_nickname_format functions. The silc_asn1_encoder function in lib/silcasn1/silcasn1_encode.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.8 allows remote attackers to overwrite a stack location and possibly execute arbitrary code via a crafted OID value, related to incorrect use of a %lu format string. The silc_http_server_parse function in lib/silchttp/silchttpserver.c in the internal HTTP server in silcd in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.9 allows remote attackers to overwrite a stack location and possibly execute arbitrary code via a crafted Content-Length header, related to incorrect use of a %lu format string. Multiple format string vulnerabilities in lib/silcclient/command.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.10, and SILC Client 1.1.8 and earlier, allow remote attackers to execute arbitrary code via format string specifiers in a channel name, related to (1) silc_client_command_topic, (2) silc_client_command_kick, (3) silc_client_command_leave, and (4) silc_client_command_users. This update provides a solution to these vulnerabilities. Packages for MES5 was not provided previously, this update addresses this problem. Packages for 2008.0 are being provided due to extended support for Corporate products.

tags | advisory, remote, web, arbitrary, vulnerability
systems | linux, mandriva
advisories | CVE-2009-3051, CVE-2008-7159, CVE-2008-7160, CVE-2009-3163
SHA-256 | ae55c02dbd7ddd57b43075845ae46ba5e33dc5158dd2ff5097cba115e8693937
Mandriva Linux Security Advisory 2009-234
Posted Sep 16, 2009
Authored by Mandriva | Site mandriva.com

Mandriva Linux Security Advisory 2009-234-1 - Multiple vulnerabilities was discovered and corrected in silc-toolkit. Packages for MES5 was not provided previously, this update addresses this problem.

tags | advisory, vulnerability
systems | linux, mandriva
advisories | CVE-2009-3051, CVE-2008-7159, CVE-2008-7160, CVE-2009-3163
SHA-256 | a51514cfad73cb0fd5f059dc25c98f0dd860e2efc681c5539304259b50a7f217
Mandriva Linux Security Advisory 2009-234
Posted Sep 16, 2009
Authored by Mandriva | Site mandriva.com

Mandriva Linux Security Advisory 2009-234 - Multiple vulnerabilities was discovered and corrected in silc-toolkit.

tags | advisory, vulnerability
systems | linux, mandriva
advisories | CVE-2009-3051, CVE-2008-7159, CVE-2008-7160, CVE-2009-3163
SHA-256 | d2d335c7fee04bb290f003b33d57677946c5ac8ee24f25bc7797d651892312ab
Debian Linux Security Advisory 1879-1
Posted Sep 4, 2009
Authored by Debian | Site debian.org

Debian Security Advisory 1879-1 - Several vulnerabilities have been discovered in the software suite for the SILC protocol, a network protocol designed to provide end-to-end security for conferencing services.

tags | advisory, vulnerability, protocol
systems | linux, debian
advisories | CVE-2008-7159, CVE-2008-7160, CVE-2009-3051
SHA-256 | a579706ca3462dbced3ea936bf4e6108a3458c47e92f30831ef87990788d6e50
Page 1 of 1
Back1Next

File Archive:

February 2024

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Feb 1st
    16 Files
  • 2
    Feb 2nd
    19 Files
  • 3
    Feb 3rd
    0 Files
  • 4
    Feb 4th
    0 Files
  • 5
    Feb 5th
    24 Files
  • 6
    Feb 6th
    2 Files
  • 7
    Feb 7th
    10 Files
  • 8
    Feb 8th
    25 Files
  • 9
    Feb 9th
    37 Files
  • 10
    Feb 10th
    0 Files
  • 11
    Feb 11th
    0 Files
  • 12
    Feb 12th
    17 Files
  • 13
    Feb 13th
    20 Files
  • 14
    Feb 14th
    25 Files
  • 15
    Feb 15th
    15 Files
  • 16
    Feb 16th
    6 Files
  • 17
    Feb 17th
    0 Files
  • 18
    Feb 18th
    0 Files
  • 19
    Feb 19th
    35 Files
  • 20
    Feb 20th
    25 Files
  • 21
    Feb 21st
    0 Files
  • 22
    Feb 22nd
    0 Files
  • 23
    Feb 23rd
    0 Files
  • 24
    Feb 24th
    0 Files
  • 25
    Feb 25th
    0 Files
  • 26
    Feb 26th
    0 Files
  • 27
    Feb 27th
    0 Files
  • 28
    Feb 28th
    0 Files
  • 29
    Feb 29th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close