what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New
Showing 1 - 4 of 4 RSS Feed

CVE-2008-0666

Status Candidate

Overview

Website META Language (WML) 2.0.11 allows local users to overwrite arbitrary files via a symlink attack on (1) the /tmp/pe.tmp.$$ temporary file used by wml_contrib/wmg.cgi and (2) temporary files used by wml_backend/p3_eperl/eperl_sys.c.

Related Files

Debian Linux Security Advisory 1492-2
Posted Apr 28, 2008
Authored by Debian | Site debian.org

Debian Security Advisory 1492-2 - The security update DSA 1492-1 fixed the security problem below but introduced a new problem by not removing temporary directories in the ipp backend. This update corrects this.

tags | advisory
systems | linux, debian
advisories | CVE-2008-0665, CVE-2008-0666
SHA-256 | edba386bcdc10d931bd1d6867df5086613efae03838af9ea9ee09515e8823f78
Mandriva Linux Security Advisory 2008-076
Posted Mar 26, 2008
Authored by Mandriva | Site mandriva.com

Mandriva Linux Security Advisory - Two vulnerabilities were found in the Website META Language (WML) package that allowed local users to overwrite arbitrary files via symlink attacks.

tags | advisory, arbitrary, local, vulnerability
systems | linux, mandriva
advisories | CVE-2008-0665, CVE-2008-0666
SHA-256 | 642f93fb28c1a2234f77263f6160cec95cf0a8097345eac770f28404eaf2d0ff
Gentoo Linux Security Advisory 200803-23
Posted Mar 17, 2008
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory GLSA 200803-23 - Temporary files are handled insecurely in the files wml_backend/p1_ipp/ipp.src, wml_contrib/wmg.cgi, and wml_backend/p3_eperl/eperl_sys.c, allowing users to overwrite or delete arbitrary files with the privileges of the user running the program. Versions less than 2.0.11-r3 are affected.

tags | advisory, arbitrary, cgi
systems | linux, gentoo
advisories | CVE-2008-0665, CVE-2008-0666
SHA-256 | 07671863f85e01c5df4c87bfa17db9834feb97b078d5401ba2ffcb4152c1fe9c
Debian Linux Security Advisory 1492-1
Posted Feb 11, 2008
Authored by Debian | Site debian.org

Debian Security Advisory 1492-1 - Frank Lichtenheld and Nico Golde discovered that WML, an off-line HTML generation toolkit, creates insecure temporary files in the eperl and ipp backends and in the wmg.cgi script, which could lead to local denial of service by overwriting files.

tags | advisory, denial of service, local, cgi
systems | linux, debian
advisories | CVE-2008-0665, CVE-2008-0666
SHA-256 | 968cbf15656caec7816b6646a9f9246a60c3937d49be8c28ef1849441ab6e468
Page 1 of 1
Back1Next

File Archive:

March 2023

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Mar 1st
    16 Files
  • 2
    Mar 2nd
    13 Files
  • 3
    Mar 3rd
    15 Files
  • 4
    Mar 4th
    0 Files
  • 5
    Mar 5th
    0 Files
  • 6
    Mar 6th
    16 Files
  • 7
    Mar 7th
    31 Files
  • 8
    Mar 8th
    16 Files
  • 9
    Mar 9th
    13 Files
  • 10
    Mar 10th
    9 Files
  • 11
    Mar 11th
    0 Files
  • 12
    Mar 12th
    0 Files
  • 13
    Mar 13th
    10 Files
  • 14
    Mar 14th
    6 Files
  • 15
    Mar 15th
    17 Files
  • 16
    Mar 16th
    22 Files
  • 17
    Mar 17th
    13 Files
  • 18
    Mar 18th
    0 Files
  • 19
    Mar 19th
    0 Files
  • 20
    Mar 20th
    16 Files
  • 21
    Mar 21st
    13 Files
  • 22
    Mar 22nd
    5 Files
  • 23
    Mar 23rd
    6 Files
  • 24
    Mar 24th
    47 Files
  • 25
    Mar 25th
    0 Files
  • 26
    Mar 26th
    0 Files
  • 27
    Mar 27th
    50 Files
  • 28
    Mar 28th
    42 Files
  • 29
    Mar 29th
    7 Files
  • 30
    Mar 30th
    31 Files
  • 31
    Mar 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close