what you don't know can hurt you
Home Files News &[SERVICES_TAB]About Contact Add New
Showing 1 - 11 of 11 RSS Feed

Files from SpringSource Security Team

Email addresssecurity at springsource.com
First Active2009-10-05
Last Active2011-09-09
Spring Security RunAsManager Privilege Escalation
Posted Sep 9, 2011
Authored by SpringSource Security Team, Rob Winch

Spring Security provides a mechanism (RunAsManager) to allow particular operations to run with a different set of privileges than the predefined user. The implementation contains a race condition whereby the escalated privileges could also be used in a different invocation in another thread. Versions 2.0.0 to 2.0.6 and 3.0.0 to 3.0.5 are affected.

tags | advisory
advisories | CVE-2011-2731
SHA-256 | 47b96c9de342642c2cd4e172c544b89e012a3797e75972454bb8c77cb5091e42
Spring Framework / Spring Security Serialization-Based Issues
Posted Sep 9, 2011
Authored by Wouter Coekaerts, SpringSource Security Team

Spring Framework versions 3.0.0 to 3.0.5 and Spring Security versions 2.0.0 to 2.0.6 and 3.0.0 to 3.0.5 suffer from serialization issues. Several issues have been reported which may affect applications which de-serialize objects from an untrusted source such as a remote client. It is possible for a malicious client to inject undesirable behavior into the server by serializing proxies rather than specific class instances, or by taking advantage of internal AOP interfaces which were being exposed through the remote service, in addition to the service interface.

tags | advisory, remote
advisories | CVE-2011-2894
SHA-256 | f905e5bf5433c31b6e389d1aca05670a117b1f5976e8502215745fe22fe34fc4
Spring Security Header Injection
Posted Sep 9, 2011
Authored by SpringSource Security Team, David Mas

Spring Security allows the use of a parameter (named "spring-security-redirect" by default) to determine the location URL to which a user will be redirected after logging in. This will normally be submitted as part of the login request, so is deemed to be an acceptable use of remote supplied data. However, the functionality is in a base class which is also shared by logout code, so a logout URL could be maliciously constructed to contain a version of this parameter which contained CRLF characters in order to inject additional headers or split the response. Versions 2.0.0 to 2.0.6 and 3.0.0 to 3.0.5 are affected.

tags | exploit, remote
advisories | CVE-2011-2732
SHA-256 | 190a53655a53fda33bb5be21ed5b61b82d8ef40a6afea588925d6719c66f2ba0
Spring Framework Information Disclosure
Posted Sep 9, 2011
Authored by Stefano Di Paola, Arshan Dabirsiaghi, SpringSource Security Team

Spring Framework versions 3.0.0 to 3.0.5, 2.5.0 to 2.5.6.SEC02, and 2.5.0 to 2.5.7.SR01 suffer from an information disclosure vulnerability.

tags | advisory, info disclosure
advisories | CVE-2011-2730
SHA-256 | f0dc757e73d89236f2c88698d4791d1317a31be811db0b76dade2bee53c8a3d7
VMware vFabric tc Server Password Obfuscation Bypass
Posted Aug 12, 2011
Authored by SpringSource Security Team

VMware vFabric tc Server allows users to store the passwords used for JMX authentication in an obfuscated form for organizations where storing passwords in plain text is not permitted. The JMX authentication implementation was incorrectly allowing users to authenticate using the password in either its plain text form or its obfuscated form, bypassing the benefit of obfuscation. Versions 2.0.0.RELEASE to 2.0.5.SR01 and 2.1.0.RELEASE to 2.1.1.SR01 are affected.

tags | advisory
SHA-256 | a23ea5d133c5ea0c5b2775fefc4fcbc7cf7cf5fcd577cd7b417bb806221241f5
Apache Shiro Information Disclosure
Posted Nov 4, 2010
Authored by SpringSource Security Team

Apache Shiro version 1.0.0-incubating suffers from an information disclosure vulnerability. Shiro's path-based filter chain mechanism did not normalize request paths before performing path-matching logic. The result is that Shiro filter chain matching logic was susceptible to potential path traversal attacks.

tags | exploit, info disclosure
advisories | CVE-2010-3863
SHA-256 | edbfc654a617fb75fdde37febf48f3584026969f760f1650e56dd5ba41ffad08
Spring Security Security Constraint Bypass
Posted Oct 28, 2010
Authored by SpringSource Security Team

Spring Security does not consider URL path parameters when processing security constraints. By adding an URL path parameter to a request, an attacker may be able to bypass a security constraint. The root cause of this issue is a lack of clarity regarding the handling of path parameters in the Servlet Specification (see below). Some Servlet containers include path parameters in the value returned for getPathInfo() and some do not. Spring Security uses the value returned by getPathInfo() as part of the process of mapping requests to security constraints. The unexpected presence of path parameters can cause a constraint to be bypassed.

tags | exploit, root, bypass
advisories | CVE-2010-3700
SHA-256 | 429e4cf5e844ee3703c922909bb8c267c6740efb53e7fb37de08a3f14ccacd09
SpringSource tc Server Unauthenticated Remote Access
Posted May 19, 2010
Authored by SpringSource Security Team

The SpringSource tc Server suffers from an unauthenticated remote access vulnerability in relation to the JMX interface.

tags | advisory, remote, bypass
advisories | CVE-2010-1454
SHA-256 | d8837f97c98e36f3dfe3aaa8777b942e3480fd0ee9a2827b13650cfc14baeaa2
SpringSource Hyperic HQ Cross Site Scripting
Posted Mar 23, 2010
Authored by SpringSource Security Team

SpringSource Hyperic HQ suffers from multiple stored cross site scripting vulnerability.

tags | exploit, xss
advisories | CVE-2009-2907
SHA-256 | 10513634324c50825e0c403f5eec29293c1318a9c53dd4584caab3a181828a8c
SpringSource Stored Cross Site Scripting
Posted Oct 5, 2009
Authored by SpringSource Security Team

SpringSource versions Hyperic HQ 3.2, 4.0, 4.1, and 4.2-beta1 suffer from a stored cross site scripting vulnerability.

tags | advisory, xss
advisories | CVE-2009-2898
SHA-256 | cf606ddcc8f82d68dce7d9dc35eb9ecb409d12d529769c995e1498eabc1611eb
SpringSource Reflected Cross Site Scripting
Posted Oct 5, 2009
Authored by SpringSource Security Team

SpringSource versions Hyperic HQ 3.2, 4.0, 4.1, and 4.2-beta1 suffer from a reflected cross site scripting vulnerability.

tags | advisory, xss
advisories | CVE-2009-2897
SHA-256 | c64a153a6422c9754fa7f2877f9b124a2a88dc586ef80026cf60df594e722ae2
Page 1 of 1
Back1Next

File Archive:

August 2022

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Aug 1st
    20 Files
  • 2
    Aug 2nd
    4 Files
  • 3
    Aug 3rd
    6 Files
  • 4
    Aug 4th
    55 Files
  • 5
    Aug 5th
    16 Files
  • 6
    Aug 6th
    0 Files
  • 7
    Aug 7th
    0 Files
  • 8
    Aug 8th
    13 Files
  • 9
    Aug 9th
    13 Files
  • 10
    Aug 10th
    34 Files
  • 11
    Aug 11th
    16 Files
  • 12
    Aug 12th
    5 Files
  • 13
    Aug 13th
    0 Files
  • 14
    Aug 14th
    0 Files
  • 15
    Aug 15th
    25 Files
  • 16
    Aug 16th
    0 Files
  • 17
    Aug 17th
    0 Files
  • 18
    Aug 18th
    0 Files
  • 19
    Aug 19th
    0 Files
  • 20
    Aug 20th
    0 Files
  • 21
    Aug 21st
    0 Files
  • 22
    Aug 22nd
    0 Files
  • 23
    Aug 23rd
    0 Files
  • 24
    Aug 24th
    0 Files
  • 25
    Aug 25th
    0 Files
  • 26
    Aug 26th
    0 Files
  • 27
    Aug 27th
    0 Files
  • 28
    Aug 28th
    0 Files
  • 29
    Aug 29th
    0 Files
  • 30
    Aug 30th
    0 Files
  • 31
    Aug 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close