exploit the possibilities

Ubuntu Security Notice USN-4372-1

Ubuntu Security Notice USN-4372-1
Posted May 21, 2020
Authored by Ubuntu | Site security.ubuntu.com

Ubuntu Security Notice 4372-1 - It was discovered that QEMU incorrectly handled bochs-display devices. A local attacker in a guest could use this to cause a denial of service or possibly execute arbitrary code in the host. This issue only affected Ubuntu 19.10. It was discovered that QEMU incorrectly handled memory during certain VNC operations. A remote attacker could possibly use this issue to cause QEMU to consume resources, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.10. Various other issues were also addressed.

tags | advisory, remote, denial of service, arbitrary, local
systems | linux, ubuntu
advisories | CVE-2019-15034, CVE-2019-20382, CVE-2020-10702, CVE-2020-11869, CVE-2020-1983
MD5 | abf7184cc2087c06b76ddc60ed0d60ed

Ubuntu Security Notice USN-4372-1

Change Mirror Download
==========================================================================
Ubuntu Security Notice USN-4372-1
May 21, 2020

qemu vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 19.10
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in QEMU.

Software Description:
- qemu: Machine emulator and virtualizer

Details:

It was discovered that QEMU incorrectly handled bochs-display devices. A
local attacker in a guest could use this to cause a denial of service or
possibly execute arbitrary code in the host. This issue only affected
Ubuntu 19.10. (CVE-2019-15034)

It was discovered that QEMU incorrectly handled memory during certain VNC
operations. A remote attacker could possibly use this issue to cause QEMU
to consume resources, resulting in a denial of service. This issue only
affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.10.
(CVE-2019-20382)

It was discovered that QEMU incorrectly generated QEMU Pointer
Authentication signatures on ARM. A local attacker could possibly use this
issue to bypass PAuth. This issue only affected Ubuntu 19.10.
(CVE-2020-10702)

Ziming Zhang discovered that QEMU incorrectly handled ATI VGA emulation. A
local attacker in a guest could use this issue to cause QEMU to crash,
resulting in a denial of service. This issue only affected Ubuntu 20.04
LTS. (CVE-2020-11869)

Aviv Sasson discovered that QEMU incorrectly handled Slirp networking. A
remote attacker could use this issue to cause QEMU to crash, resulting in a
denial of service, or possibly execute arbitrary code. This issue only
affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.10.
(CVE-2020-1983)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
qemu 1:4.2-3ubuntu6.1
qemu-system 1:4.2-3ubuntu6.1
qemu-system-arm 1:4.2-3ubuntu6.1
qemu-system-mips 1:4.2-3ubuntu6.1
qemu-system-ppc 1:4.2-3ubuntu6.1
qemu-system-s390x 1:4.2-3ubuntu6.1
qemu-system-sparc 1:4.2-3ubuntu6.1
qemu-system-x86 1:4.2-3ubuntu6.1

Ubuntu 19.10:
qemu 1:4.0+dfsg-0ubuntu9.6
qemu-system 1:4.0+dfsg-0ubuntu9.6
qemu-system-arm 1:4.0+dfsg-0ubuntu9.6
qemu-system-mips 1:4.0+dfsg-0ubuntu9.6
qemu-system-ppc 1:4.0+dfsg-0ubuntu9.6
qemu-system-s390x 1:4.0+dfsg-0ubuntu9.6
qemu-system-sparc 1:4.0+dfsg-0ubuntu9.6
qemu-system-x86 1:4.0+dfsg-0ubuntu9.6

Ubuntu 18.04 LTS:
qemu 1:2.11+dfsg-1ubuntu7.26
qemu-system 1:2.11+dfsg-1ubuntu7.26
qemu-system-arm 1:2.11+dfsg-1ubuntu7.26
qemu-system-mips 1:2.11+dfsg-1ubuntu7.26
qemu-system-ppc 1:2.11+dfsg-1ubuntu7.26
qemu-system-s390x 1:2.11+dfsg-1ubuntu7.26
qemu-system-sparc 1:2.11+dfsg-1ubuntu7.26
qemu-system-x86 1:2.11+dfsg-1ubuntu7.26

Ubuntu 16.04 LTS:
qemu 1:2.5+dfsg-5ubuntu10.44
qemu-system 1:2.5+dfsg-5ubuntu10.44
qemu-system-aarch64 1:2.5+dfsg-5ubuntu10.44
qemu-system-arm 1:2.5+dfsg-5ubuntu10.44
qemu-system-mips 1:2.5+dfsg-5ubuntu10.44
qemu-system-ppc 1:2.5+dfsg-5ubuntu10.44
qemu-system-s390x 1:2.5+dfsg-5ubuntu10.44
qemu-system-sparc 1:2.5+dfsg-5ubuntu10.44
qemu-system-x86 1:2.5+dfsg-5ubuntu10.44

After a standard system update you need to restart all QEMU virtual
machines to make all the necessary changes.

References:
https://usn.ubuntu.com/4372-1
CVE-2019-15034, CVE-2019-20382, CVE-2020-10702, CVE-2020-11869,
CVE-2020-1983

Package Information:
https://launchpad.net/ubuntu/+source/qemu/1:4.2-3ubuntu6.1
https://launchpad.net/ubuntu/+source/qemu/1:4.0+dfsg-0ubuntu9.6
https://launchpad.net/ubuntu/+source/qemu/1:2.11+dfsg-1ubuntu7.26
https://launchpad.net/ubuntu/+source/qemu/1:2.5+dfsg-5ubuntu10.44

Login or Register to add favorites

File Archive:

May 2020

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    May 1st
    14 Files
  • 2
    May 2nd
    3 Files
  • 3
    May 3rd
    1 Files
  • 4
    May 4th
    18 Files
  • 5
    May 5th
    15 Files
  • 6
    May 6th
    21 Files
  • 7
    May 7th
    15 Files
  • 8
    May 8th
    19 Files
  • 9
    May 9th
    1 Files
  • 10
    May 10th
    2 Files
  • 11
    May 11th
    18 Files
  • 12
    May 12th
    39 Files
  • 13
    May 13th
    15 Files
  • 14
    May 14th
    17 Files
  • 15
    May 15th
    17 Files
  • 16
    May 16th
    2 Files
  • 17
    May 17th
    2 Files
  • 18
    May 18th
    15 Files
  • 19
    May 19th
    21 Files
  • 20
    May 20th
    15 Files
  • 21
    May 21st
    15 Files
  • 22
    May 22nd
    6 Files
  • 23
    May 23rd
    1 Files
  • 24
    May 24th
    1 Files
  • 25
    May 25th
    2 Files
  • 26
    May 26th
    23 Files
  • 27
    May 27th
    13 Files
  • 28
    May 28th
    18 Files
  • 29
    May 29th
    17 Files
  • 30
    May 30th
    0 Files
  • 31
    May 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2020 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close