exploit the possibilities

Red Hat Security Advisory 2020-1475-01

Red Hat Security Advisory 2020-1475-01
Posted Apr 15, 2020
Authored by Red Hat | Site access.redhat.com

Red Hat Security Advisory 2020-1475-01 - Red Hat CodeReady Workspaces 2.1.0 provides a cloud developer-workspace server and a browser-based IDE built for teams and organizations. CodeReady Workspaces runs in OpenShift and is well-suited for container-based development. Issues addressed include a bypass vulnerability.

tags | advisory, bypass
systems | linux, redhat
advisories | CVE-2019-1348, CVE-2019-1349, CVE-2019-1352, CVE-2019-13734, CVE-2019-1387, CVE-2019-15030, CVE-2019-15031, CVE-2019-18397, CVE-2019-18408, CVE-2019-18660, CVE-2019-19527, CVE-2020-10531, CVE-2020-10689, CVE-2020-1712
MD5 | cbcb48e9bff6c89d5f8b0f777692f831

Red Hat Security Advisory 2020-1475-01

Change Mirror Download
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

====================================================================
Red Hat Security Advisory

Synopsis: Moderate: Red Hat CodeReady Workspaces 2.1.0 release
Advisory ID: RHSA-2020:1475-01
Product: Red Hat CodeReady Workspaces
Advisory URL: https://access.redhat.com/errata/RHSA-2020:1475
Issue date: 2020-04-14
CVE Names: CVE-2019-1348 CVE-2019-1349 CVE-2019-1352
CVE-2019-1387 CVE-2019-13734 CVE-2019-15030
CVE-2019-15031 CVE-2019-18397 CVE-2019-18408
CVE-2019-18660 CVE-2019-19527 CVE-2020-1712
CVE-2020-10531 CVE-2020-10689
====================================================================
1. Summary:

Red Hat CodeReady Workspaces 2.1.0 has been released.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Description:

Red Hat CodeReady Workspaces 2.1.0 provides a cloud developer-workspace
server and a browser-based IDE built for teams and organizations. CodeReady
Workspaces runs in OpenShift and is well-suited for container-based
development.

This major release is based on Eclipse Che 7.9 and offers security fixes
and a number of enhancements and new features, including:

Security fix:

* JWT proxy bypass allows access to workspace pods of other users
(CVE-2020-10689)

Enhancements and new features:

* Improved code samples for default devfiles
* Improved naming of default stacks
* Updated .NET sample (including debugger) to version 3.1
* Enabled offline devfile registry

For more details about the security issue, including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page listed in the References section.

This update includes updated container images, which are based on an
updated Red Hat Enterprise Linux image that contains fixes for the
following issues:

CVE-2019-1348, CVE-2019-1349, CVE-2019-1352, CVE-2019-1387, CVE-2019-13734,
CVE-2019-15030, CVE-2019-15031, CVE-2019-16775, CVE-2019-16776,
CVE-2019-16777, CVE-2019-18397, CVE-2019-18408, CVE-2019-18660,
CVE-2019-19527, CVE-2020-1712, CVE-2020-10531

3. Solution:

To start using CodeReady Workspaces, download and install it using the
instructions provided in the Red Hat CodeReady Workspaces Installation
Guide linked from the References section.

4. Bugs fixed (https://bugzilla.redhat.com/):

1816789 - CVE-2020-10689 che: pods in kubernetes cluster can bypass JWT proxy and send unauthenticated requests to workspace pods

5. JIRA issues fixed (https://issues.jboss.org/):

CRW-402 - CRW 2.1 devfiles
CRW-507 - CRW 2.1 Overall Epic
CRW-510 - When not using TLS, Openshift plugin does not allow login via UI (but does work via console login)
CRW-533 - Factory are never redirecting to the IDE once loaded
CRW-535 - update factories link in CRW dashboard to point to updated user doc
CRW-537 - Patches in che-theia repo for theia are not applied in crw-theia build
CRW-544 - CRW 2.1 plugins+images
CRW-572 - Node 10 example results in "Error: Cannot find module 'express'"
CRW-573 - CRW 2.0.x branding update
CRW-574 - Cannot inject a devfile or plugin at runtime (container doesn't include yq or build scripts)
CRW-784 - Tag not replaced by digest in the `latest` version of plugins in the registry

6. References:

https://access.redhat.com/security/cve/CVE-2019-1348
https://access.redhat.com/security/cve/CVE-2019-1349
https://access.redhat.com/security/cve/CVE-2019-1352
https://access.redhat.com/security/cve/CVE-2019-1387
https://access.redhat.com/security/cve/CVE-2019-13734
https://access.redhat.com/security/cve/CVE-2019-15030
https://access.redhat.com/security/cve/CVE-2019-15031
https://access.redhat.com/security/cve/CVE-2019-18397
https://access.redhat.com/security/cve/CVE-2019-18408
https://access.redhat.com/security/cve/CVE-2019-18660
https://access.redhat.com/security/cve/CVE-2019-19527
https://access.redhat.com/security/cve/CVE-2020-1712
https://access.redhat.com/security/cve/CVE-2020-10531
https://access.redhat.com/security/cve/CVE-2020-10689
https://access.redhat.com/security/updates/classification/#moderate
https://access.redhat.com/documentation/en-us/red_hat_codeready_workspaces/2.1/html-single/installation_guide/

7. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2020 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXpYPOtzjgjWX9erEAQgbRQ//T/NfSe9lcn7evkrA6jhkLsEhe0eWDLQr
K+HipXOPawoNKz6rKL/NHcL4FqF54E0qSz7kk8+lddqVtanY560VVViexoiqwD5P
ienk8RseuZQlVTEPvClhzRfn29iZD9Bgjef1M8b+KbxiNDU/8hbRxjkw1qpUV2RR
bJAc+hq1mBYaYCGFvaGKNJiDEfdN0Plxm0g9tANxMzWfFZbmNsfHlA/pKNI1ijPv
VMVeMBRww6LmgADtqkRvaHW2WpQKu4wmv1k/UZ+WGmtzEngPxYUDdaRTaraZFDHl
ALXHfpZtiaMtTkdPTZk9kROKS08q8dhe87XcCB/5SvqsQgf094P+fvfJl090W44w
rNkt9CmIFteFOkMJc5+tDIgbgDC6I7vBHjYKewJvKgf4IeSGcfvNhiXFVvtX6P1l
NEx+qNxSUIuqSkS+geNNUuBcyRsAoi/0qgFpwbKRz/qe7sDQRuw5t4Hsbcn2xLs2
4xiqLqO14oZ78UsXdf46AQt+mJaNop3xvwQ+g1aMd/gNZ2ZXyXdLPxvMJQMGW4+V
fldaMCr6deIWgjhJ3rlDceMm7YLD0l42/cnLZtX1rz5taygsHkw7nq1tsNpXDPj1
1Gh/T6y2rEn6all+Q48xUQb3CrofzvJhxvfsENo3g8tMtIXchOJM65ajKGZFwy7h
9YPV5gz65bs=eiue
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Login or Register to add favorites

File Archive:

October 2020

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Oct 1st
    25 Files
  • 2
    Oct 2nd
    13 Files
  • 3
    Oct 3rd
    1 Files
  • 4
    Oct 4th
    1 Files
  • 5
    Oct 5th
    15 Files
  • 6
    Oct 6th
    15 Files
  • 7
    Oct 7th
    15 Files
  • 8
    Oct 8th
    11 Files
  • 9
    Oct 9th
    3 Files
  • 10
    Oct 10th
    1 Files
  • 11
    Oct 11th
    1 Files
  • 12
    Oct 12th
    8 Files
  • 13
    Oct 13th
    12 Files
  • 14
    Oct 14th
    23 Files
  • 15
    Oct 15th
    4 Files
  • 16
    Oct 16th
    13 Files
  • 17
    Oct 17th
    1 Files
  • 18
    Oct 18th
    1 Files
  • 19
    Oct 19th
    27 Files
  • 20
    Oct 20th
    0 Files
  • 21
    Oct 21st
    0 Files
  • 22
    Oct 22nd
    0 Files
  • 23
    Oct 23rd
    0 Files
  • 24
    Oct 24th
    0 Files
  • 25
    Oct 25th
    0 Files
  • 26
    Oct 26th
    0 Files
  • 27
    Oct 27th
    0 Files
  • 28
    Oct 28th
    0 Files
  • 29
    Oct 29th
    0 Files
  • 30
    Oct 30th
    0 Files
  • 31
    Oct 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2020 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close