exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New

Red Hat Security Advisory 2019-2955-01

Red Hat Security Advisory 2019-2955-01
Posted Oct 2, 2019
Authored by Red Hat | Site access.redhat.com

Red Hat Security Advisory 2019-2955-01 - Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Issues addressed include a denial of service vulnerability.

tags | advisory, denial of service, javascript
systems | linux, redhat
advisories | CVE-2019-9511, CVE-2019-9512, CVE-2019-9513, CVE-2019-9514, CVE-2019-9515, CVE-2019-9516, CVE-2019-9517, CVE-2019-9518
SHA-256 | b7162517675b1868f60c53163c81b309fb76841f9ffbd714085b890a5ced1f17

Red Hat Security Advisory 2019-2955-01

Change Mirror Download
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

====================================================================
Red Hat Security Advisory

Synopsis: Important: rh-nodejs8-nodejs security update
Advisory ID: RHSA-2019:2955-01
Product: Red Hat Software Collections
Advisory URL: https://access.redhat.com/errata/RHSA-2019:2955
Issue date: 2019-10-02
CVE Names: CVE-2019-9511 CVE-2019-9512 CVE-2019-9513
CVE-2019-9514 CVE-2019-9515 CVE-2019-9516
CVE-2019-9517 CVE-2019-9518
====================================================================
1. Summary:

An update for rh-nodejs8-nodejs is now available for Red Hat Software
Collections.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - aarch64, noarch, ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5) - noarch, ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) - noarch, ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) - noarch, ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - noarch, x86_64

3. Description:

Node.js is a software development platform for building fast and scalable
network applications in the JavaScript programming language.

The following packages have been upgraded to a later upstream version:
rh-nodejs8-nodejs (8.16.1).

Security Fix(es):

* HTTP/2: large amount of data requests leads to denial of service
(CVE-2019-9511)

* HTTP/2: flood using PING frames results in unbounded memory growth
(CVE-2019-9512)

* HTTP/2: flood using PRIORITY frames results in excessive resource
consumption (CVE-2019-9513)

* HTTP/2: flood using HEADERS frames results in unbounded memory growth
(CVE-2019-9514)

* HTTP/2: flood using SETTINGS frames results in unbounded memory growth
(CVE-2019-9515)

* HTTP/2: 0-length headers lead to denial of service (CVE-2019-9516)

* HTTP/2: request for large response leads to denial of service
(CVE-2019-9517)

* HTTP/2: flood using empty frames results in excessive resource
consumption (CVE-2019-9518)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1735645 - CVE-2019-9512 HTTP/2: flood using PING frames results in unbounded memory growth
1735741 - CVE-2019-9513 HTTP/2: flood using PRIORITY frames results in excessive resource consumption
1735744 - CVE-2019-9514 HTTP/2: flood using HEADERS frames results in unbounded memory growth
1735745 - CVE-2019-9515 HTTP/2: flood using SETTINGS frames results in unbounded memory growth
1735749 - CVE-2019-9518 HTTP/2: flood using empty frames results in excessive resource consumption
1741860 - CVE-2019-9511 HTTP/2: large amount of data requests leads to denial of service
1741864 - CVE-2019-9516 HTTP/2: 0-length headers lead to denial of service
1741868 - CVE-2019-9517 HTTP/2: request for large response leads to denial of service

6. Package List:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

aarch64:
rh-nodejs8-3.0-5.el7.aarch64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.aarch64.rpm
rh-nodejs8-runtime-3.0-5.el7.aarch64.rpm
rh-nodejs8-scldevel-3.0-5.el7.aarch64.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

ppc64le:
rh-nodejs8-3.0-5.el7.ppc64le.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.ppc64le.rpm
rh-nodejs8-runtime-3.0-5.el7.ppc64le.rpm
rh-nodejs8-scldevel-3.0-5.el7.ppc64le.rpm

s390x:
rh-nodejs8-3.0-5.el7.s390x.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.s390x.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.s390x.rpm
rh-nodejs8-runtime-3.0-5.el7.s390x.rpm
rh-nodejs8-scldevel-3.0-5.el7.s390x.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

aarch64:
rh-nodejs8-3.0-5.el7.aarch64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.aarch64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.aarch64.rpm
rh-nodejs8-runtime-3.0-5.el7.aarch64.rpm
rh-nodejs8-scldevel-3.0-5.el7.aarch64.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

ppc64le:
rh-nodejs8-3.0-5.el7.ppc64le.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.ppc64le.rpm
rh-nodejs8-runtime-3.0-5.el7.ppc64le.rpm
rh-nodejs8-scldevel-3.0-5.el7.ppc64le.rpm

s390x:
rh-nodejs8-3.0-5.el7.s390x.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.s390x.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.s390x.rpm
rh-nodejs8-runtime-3.0-5.el7.s390x.rpm
rh-nodejs8-scldevel-3.0-5.el7.s390x.rpm

x86_64:
rh-nodejs8-3.0-5.el7.x86_64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.x86_64.rpm
rh-nodejs8-runtime-3.0-5.el7.x86_64.rpm
rh-nodejs8-scldevel-3.0-5.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.5):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

ppc64le:
rh-nodejs8-3.0-5.el7.ppc64le.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.ppc64le.rpm
rh-nodejs8-runtime-3.0-5.el7.ppc64le.rpm
rh-nodejs8-scldevel-3.0-5.el7.ppc64le.rpm

s390x:
rh-nodejs8-3.0-5.el7.s390x.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.s390x.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.s390x.rpm
rh-nodejs8-runtime-3.0-5.el7.s390x.rpm
rh-nodejs8-scldevel-3.0-5.el7.s390x.rpm

x86_64:
rh-nodejs8-3.0-5.el7.x86_64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.x86_64.rpm
rh-nodejs8-runtime-3.0-5.el7.x86_64.rpm
rh-nodejs8-scldevel-3.0-5.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

ppc64le:
rh-nodejs8-3.0-5.el7.ppc64le.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.ppc64le.rpm
rh-nodejs8-runtime-3.0-5.el7.ppc64le.rpm
rh-nodejs8-scldevel-3.0-5.el7.ppc64le.rpm

s390x:
rh-nodejs8-3.0-5.el7.s390x.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.s390x.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.s390x.rpm
rh-nodejs8-runtime-3.0-5.el7.s390x.rpm
rh-nodejs8-scldevel-3.0-5.el7.s390x.rpm

x86_64:
rh-nodejs8-3.0-5.el7.x86_64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.x86_64.rpm
rh-nodejs8-runtime-3.0-5.el7.x86_64.rpm
rh-nodejs8-scldevel-3.0-5.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

ppc64le:
rh-nodejs8-3.0-5.el7.ppc64le.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.ppc64le.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.ppc64le.rpm
rh-nodejs8-runtime-3.0-5.el7.ppc64le.rpm
rh-nodejs8-scldevel-3.0-5.el7.ppc64le.rpm

s390x:
rh-nodejs8-3.0-5.el7.s390x.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.s390x.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.s390x.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.s390x.rpm
rh-nodejs8-runtime-3.0-5.el7.s390x.rpm
rh-nodejs8-scldevel-3.0-5.el7.s390x.rpm

x86_64:
rh-nodejs8-3.0-5.el7.x86_64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.x86_64.rpm
rh-nodejs8-runtime-3.0-5.el7.x86_64.rpm
rh-nodejs8-scldevel-3.0-5.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):

Source:
rh-nodejs8-3.0-5.el7.src.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.src.rpm

noarch:
rh-nodejs8-nodejs-docs-8.16.1-2.el7.noarch.rpm

x86_64:
rh-nodejs8-3.0-5.el7.x86_64.rpm
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-debuginfo-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-nodejs-devel-8.16.1-2.el7.x86_64.rpm
rh-nodejs8-npm-6.4.1-8.16.1.2.el7.x86_64.rpm
rh-nodejs8-runtime-3.0-5.el7.x86_64.rpm
rh-nodejs8-scldevel-3.0-5.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2019-9511
https://access.redhat.com/security/cve/CVE-2019-9512
https://access.redhat.com/security/cve/CVE-2019-9513
https://access.redhat.com/security/cve/CVE-2019-9514
https://access.redhat.com/security/cve/CVE-2019-9515
https://access.redhat.com/security/cve/CVE-2019-9516
https://access.redhat.com/security/cve/CVE-2019-9517
https://access.redhat.com/security/cve/CVE-2019-9518
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2019 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXZSz+NzjgjWX9erEAQhrnQ//YWmbjNrYsOnrqBPWZDBil0Basr6JUpEe
YoTqouv9A7gkpSoYLoCRE0E3tsTxHlQwJR91vlr/dPEtHbsF52YEGrumAQCK4H6b
nEhOj2pH9UG+FcPUBkyHzNQXcWYLZ9vaxVCW4gUpxm0QggyigAOdIImlZkTGgcrI
mWReipMFC8hBARJU/vQ0bCCj6LfOYnx4h2pu6Jzy+vkeVJDoCNAxGT5FwfaMZTUy
T0y8dpzWSq/vg2Xd3JaYnoh70a8k62kEMH3VmCBNNU3aiMiXBeBMlS1i/q00IOJ+
fy/1STMJGt1tj6xfYNsZY5E+CPVm0ZvVlKfRi8DpxPWXI48a712XZ/XONYb2jDnt
pmkNM62ZdjZahQwXyC+y8havivg7LcEzxV0G2yfkNIqM33Zplz0h4BOCmLuT4I84
BMylBIrODsw70uWbc1DcPsF8vhmxryGfNNQ9FCk+jH52lRi3YnWkhRBThY+rpAqZ
qmfTb4m2kD0s45q85Xv87N9F2tZJjhfYQ0U2LyHkbQov0CFkNu4YcElKMclBvvvc
lzostLzxOJYt/l3qgXp+RlQNnlQG/jsFrEmmhskjzFJ8a9fhtBWNFxMcQ+SDBrUK
HSNNzBwQhHam6OPCqpyWYvFT/bRbHucyMI6pGZmpc+MQ5cMAjP1A0incXot30UDD
wV7rh6lCkE8=S8e1
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Login or Register to add favorites

File Archive:

February 2023

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Feb 1st
    11 Files
  • 2
    Feb 2nd
    9 Files
  • 3
    Feb 3rd
    5 Files
  • 4
    Feb 4th
    0 Files
  • 5
    Feb 5th
    0 Files
  • 6
    Feb 6th
    0 Files
  • 7
    Feb 7th
    0 Files
  • 8
    Feb 8th
    0 Files
  • 9
    Feb 9th
    0 Files
  • 10
    Feb 10th
    0 Files
  • 11
    Feb 11th
    0 Files
  • 12
    Feb 12th
    0 Files
  • 13
    Feb 13th
    0 Files
  • 14
    Feb 14th
    0 Files
  • 15
    Feb 15th
    0 Files
  • 16
    Feb 16th
    0 Files
  • 17
    Feb 17th
    0 Files
  • 18
    Feb 18th
    0 Files
  • 19
    Feb 19th
    0 Files
  • 20
    Feb 20th
    0 Files
  • 21
    Feb 21st
    0 Files
  • 22
    Feb 22nd
    0 Files
  • 23
    Feb 23rd
    0 Files
  • 24
    Feb 24th
    0 Files
  • 25
    Feb 25th
    0 Files
  • 26
    Feb 26th
    0 Files
  • 27
    Feb 27th
    0 Files
  • 28
    Feb 28th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close