exploit the possibilities

Ubuntu Security Notice USN-3972-1

Ubuntu Security Notice USN-3972-1
Posted May 13, 2019
Authored by Ubuntu | Site security.ubuntu.com

Ubuntu Security Notice 3972-1 - It was discovered that PostgreSQL incorrectly handled partition routing. A remote user could possibly use this issue to read arbitrary bytes of server memory. This issue only affected Ubuntu 19.04. Dean Rasheed discovered that PostgreSQL incorrectly handled selectivity estimators. A remote attacker could possibly use this issue to bypass row security policies.

tags | advisory, remote, arbitrary
systems | linux, ubuntu
advisories | CVE-2019-10129, CVE-2019-10130
MD5 | 98ce483618e7dcc47f3eab74f1d0a501

Ubuntu Security Notice USN-3972-1

Change Mirror Download
==========================================================================
Ubuntu Security Notice USN-3972-1
May 13, 2019

postgresql-10, postgresql-11, postgresql-9.5 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.10
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in PostgreSQL.

Software Description:
- postgresql-11: object-relational SQL database
- postgresql-10: Object-relational SQL database
- postgresql-9.5: Object-relational SQL database

Details:

It was discovered that PostgreSQL incorrectly handled partition routing. A
remote user could possibly use this issue to read arbitrary bytes of server
memory. This issue only affected Ubuntu 19.04. (CVE-2019-10129)

Dean Rasheed discovered that PostgreSQL incorrectly handled selectivity
estimators. A remote attacker could possibly use this issue to bypass row
security policies. (CVE-2019-10130)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
postgresql-11 11.3-0ubuntu0.19.04.1

Ubuntu 18.10:
postgresql-10 10.8-0ubuntu0.18.10.1

Ubuntu 18.04 LTS:
postgresql-10 10.8-0ubuntu0.18.04.1

Ubuntu 16.04 LTS:
postgresql-9.5 9.5.17-0ubuntu0.16.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3972-1
CVE-2019-10129, CVE-2019-10130

Package Information:
https://launchpad.net/ubuntu/+source/postgresql-11/11.3-0ubuntu0.19.04.1
https://launchpad.net/ubuntu/+source/postgresql-10/10.8-0ubuntu0.18.10.1
https://launchpad.net/ubuntu/+source/postgresql-10/10.8-0ubuntu0.18.04.1
https://launchpad.net/ubuntu/+source/postgresql-9.5/9.5.17-0ubuntu0.16.04.1

Comments

RSS Feed Subscribe to this comment feed

No comments yet, be the first!

Login or Register to post a comment

File Archive:

May 2019

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    May 1st
    16 Files
  • 2
    May 2nd
    8 Files
  • 3
    May 3rd
    8 Files
  • 4
    May 4th
    2 Files
  • 5
    May 5th
    1 Files
  • 6
    May 6th
    15 Files
  • 7
    May 7th
    22 Files
  • 8
    May 8th
    16 Files
  • 9
    May 9th
    17 Files
  • 10
    May 10th
    16 Files
  • 11
    May 11th
    3 Files
  • 12
    May 12th
    4 Files
  • 13
    May 13th
    25 Files
  • 14
    May 14th
    24 Files
  • 15
    May 15th
    78 Files
  • 16
    May 16th
    16 Files
  • 17
    May 17th
    16 Files
  • 18
    May 18th
    2 Files
  • 19
    May 19th
    1 Files
  • 20
    May 20th
    11 Files
  • 21
    May 21st
    21 Files
  • 22
    May 22nd
    20 Files
  • 23
    May 23rd
    36 Files
  • 24
    May 24th
    2 Files
  • 25
    May 25th
    0 Files
  • 26
    May 26th
    0 Files
  • 27
    May 27th
    0 Files
  • 28
    May 28th
    0 Files
  • 29
    May 29th
    0 Files
  • 30
    May 30th
    0 Files
  • 31
    May 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2019 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close