exploit the possibilities

Gentoo Linux Security Advisory 201705-09

Gentoo Linux Security Advisory 201705-09
Posted May 18, 2017
Authored by Gentoo | Site security.gentoo.org

Gentoo Linux Security Advisory 201705-9 - Multiple vulnerabilities have been found in Apache Tomcat, the worst of which could lead to privilege escalation. Versions less than 8.0.36 are affected.

tags | advisory, vulnerability
systems | linux, gentoo
advisories | CVE-2015-5174, CVE-2015-5345, CVE-2015-5346, CVE-2015-5351, CVE-2016-0706, CVE-2016-0714, CVE-2016-0763, CVE-2016-1240, CVE-2016-3092, CVE-2016-8745, CVE-2017-5647, CVE-2017-5648, CVE-2017-5650, CVE-2017-5651
MD5 | 39dcd471a8d2d370607819953cc70df1

Gentoo Linux Security Advisory 201705-09

Change Mirror Download

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201705-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Apache Tomcat: Multiple vulnerabilities
Date: May 18, 2017
Bugs: #575796, #586966, #595978, #615868
ID: 201705-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Apache Tomcat, the worst of
which could lead to privilege escalation.

Background
==========

Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/tomcat < 8.0.36 >= 7.0.70
>= 8.0.36

Description
===========

Multiple vulnerabilities have been discovered in Tomcat. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker may be able to cause a Denial of Service condition,
obtain sensitive information, bypass protection mechanisms and
authentication restrictions.

A local attacker, who is a tomcat's system user or belongs to tomcat=E2=80=
=99s
group, could potentially escalate privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Apache Tomcat users have to manually check their Tomcat runscripts
to make sure that they don't use an old, vulnerable runscript. In
addition:

All Apache Tomcat 7 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.70:7"

All Apache Tomcat 8 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.0.36:8"

References
==========

[ 1 ] CVE-2015-5174
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5174
[ 2 ] CVE-2015-5345
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5345
[ 3 ] CVE-2015-5346
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5346
[ 4 ] CVE-2015-5351
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-5351
[ 5 ] CVE-2016-0706
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0706
[ 6 ] CVE-2016-0714
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0714
[ 7 ] CVE-2016-0763
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0763
[ 8 ] CVE-2016-1240
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-1240
[ 9 ] CVE-2016-3092
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-3092
[ 10 ] CVE-2016-8745
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-8745
[ 11 ] CVE-2017-5647
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5647
[ 12 ] CVE-2017-5648
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5648
[ 13 ] CVE-2017-5650
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5650
[ 14 ] CVE-2017-5651
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5651

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201705-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--SKKBd9VlC8wusCVbXKC9aaUtloHAjIa1g--

Comments

RSS Feed Subscribe to this comment feed

No comments yet, be the first!

Login or Register to post a comment

File Archive:

May 2019

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    May 1st
    16 Files
  • 2
    May 2nd
    8 Files
  • 3
    May 3rd
    8 Files
  • 4
    May 4th
    2 Files
  • 5
    May 5th
    1 Files
  • 6
    May 6th
    15 Files
  • 7
    May 7th
    22 Files
  • 8
    May 8th
    16 Files
  • 9
    May 9th
    17 Files
  • 10
    May 10th
    16 Files
  • 11
    May 11th
    3 Files
  • 12
    May 12th
    4 Files
  • 13
    May 13th
    25 Files
  • 14
    May 14th
    24 Files
  • 15
    May 15th
    78 Files
  • 16
    May 16th
    16 Files
  • 17
    May 17th
    12 Files
  • 18
    May 18th
    2 Files
  • 19
    May 19th
    1 Files
  • 20
    May 20th
    2 Files
  • 21
    May 21st
    16 Files
  • 22
    May 22nd
    3 Files
  • 23
    May 23rd
    0 Files
  • 24
    May 24th
    0 Files
  • 25
    May 25th
    0 Files
  • 26
    May 26th
    0 Files
  • 27
    May 27th
    0 Files
  • 28
    May 28th
    0 Files
  • 29
    May 29th
    0 Files
  • 30
    May 30th
    0 Files
  • 31
    May 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2019 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close