exploit the possibilities

Ubuntu Security Notice USN-2943-1

Ubuntu Security Notice USN-2943-1
Posted Mar 29, 2016
Authored by Ubuntu | Site security.ubuntu.com

Ubuntu Security Notice 2943-1 - It was discovered that PCRE incorrectly handled certain regular expressions. A remote attacker could use this issue to cause applications using PCRE to crash, resulting in a denial of service, or possibly execute arbitrary code.

tags | advisory, remote, denial of service, arbitrary
systems | linux, ubuntu
advisories | CVE-2014-9769, CVE-2015-2325, CVE-2015-2326, CVE-2015-2327, CVE-2015-2328, CVE-2015-3210, CVE-2015-5073, CVE-2015-8380, CVE-2015-8381, CVE-2015-8382, CVE-2015-8383, CVE-2015-8384, CVE-2015-8385, CVE-2015-8386, CVE-2015-8387, CVE-2015-8388, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8392, CVE-2015-8393, CVE-2015-8394, CVE-2015-8395, CVE-2016-1283, CVE-2016-3191
MD5 | fbd3b35e5c2cb6aa570e6b56ca4e42d5

Ubuntu Security Notice USN-2943-1

Change Mirror Download
============================================================================
Ubuntu Security Notice USN-2943-1
March 29, 2016

pcre3 vulnerabilities
============================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS

Summary:

PCRE could be made to crash or run programs if it processed a
specially-crafted regular expression.

Software Description:
- pcre3: Perl 5 Compatible Regular Expression Library

Details:

It was discovered that PCRE incorrectly handled certain regular
expressions. A remote attacker could use this issue to cause applications
using PCRE to crash, resulting in a denial of service, or possibly execute
arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
libpcre3 2:8.35-7.1ubuntu1.3

Ubuntu 14.04 LTS:
libpcre3 1:8.31-2ubuntu2.2

Ubuntu 12.04 LTS:
libpcre3 8.12-4ubuntu0.2

After a standard system update you need to restart applications using PCRE,
such as the Apache HTTP server and Nginx, to make all the necessary
changes.

References:
http://www.ubuntu.com/usn/usn-2943-1
CVE-2014-9769, CVE-2015-2325, CVE-2015-2326, CVE-2015-2327,
CVE-2015-2328, CVE-2015-3210, CVE-2015-5073, CVE-2015-8380,
CVE-2015-8381, CVE-2015-8382, CVE-2015-8383, CVE-2015-8384,
CVE-2015-8385, CVE-2015-8386, CVE-2015-8387, CVE-2015-8388,
CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8392,
CVE-2015-8393, CVE-2015-8394, CVE-2015-8395, CVE-2016-1283,
CVE-2016-3191

Package Information:
https://launchpad.net/ubuntu/+source/pcre3/2:8.35-7.1ubuntu1.3
https://launchpad.net/ubuntu/+source/pcre3/1:8.31-2ubuntu2.2
https://launchpad.net/ubuntu/+source/pcre3/8.12-4ubuntu0.2
Login or Register to add favorites

File Archive:

September 2020

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Sep 1st
    20 Files
  • 2
    Sep 2nd
    15 Files
  • 3
    Sep 3rd
    15 Files
  • 4
    Sep 4th
    4 Files
  • 5
    Sep 5th
    1 Files
  • 6
    Sep 6th
    1 Files
  • 7
    Sep 7th
    15 Files
  • 8
    Sep 8th
    27 Files
  • 9
    Sep 9th
    7 Files
  • 10
    Sep 10th
    16 Files
  • 11
    Sep 11th
    9 Files
  • 12
    Sep 12th
    0 Files
  • 13
    Sep 13th
    0 Files
  • 14
    Sep 14th
    25 Files
  • 15
    Sep 15th
    15 Files
  • 16
    Sep 16th
    15 Files
  • 17
    Sep 17th
    15 Files
  • 18
    Sep 18th
    12 Files
  • 19
    Sep 19th
    1 Files
  • 20
    Sep 20th
    1 Files
  • 21
    Sep 21st
    15 Files
  • 22
    Sep 22nd
    21 Files
  • 23
    Sep 23rd
    8 Files
  • 24
    Sep 24th
    15 Files
  • 25
    Sep 25th
    4 Files
  • 26
    Sep 26th
    0 Files
  • 27
    Sep 27th
    0 Files
  • 28
    Sep 28th
    0 Files
  • 29
    Sep 29th
    0 Files
  • 30
    Sep 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2020 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close