exploit the possibilities
Home Files News &[SERVICES_TAB]About Contact Add New

Secunia Security Advisory 51842

Secunia Security Advisory 51842
Posted Jan 21, 2013
Authored by Secunia | Site secunia.com

Secunia Security Advisory - Multiple weaknesses, two security issues, and multiple vulnerabilities have been reported in Moodle, where one has an unknown impact and the others can be exploited by malicious users to bypass certain security restrictions and by malicious people to conduct spoofing and cross-site request forgery attacks and disclose potentially sensitive information.

tags | advisory, spoof, vulnerability, csrf
SHA-256 | d7115e8feeb83f996fb130b8f96fc4dcf4c8718098cdcfed5f28cf75665d1621

Secunia Security Advisory 51842

Change Mirror Download
----------------------------------------------------------------------

The final version of the CSI 6.0 has been released.
Find out why this is not just another Patch Management solution: http://secunia.com/blog/325/

----------------------------------------------------------------------

TITLE:
Moodle Multiple Vulnerabilities

SECUNIA ADVISORY ID:
SA51842

VERIFY ADVISORY:
Secunia.com
http://secunia.com/advisories/51842/
Customer Area (Credentials Required)
https://ca.secunia.com/?page=viewadvisory&vuln_id=51842

RELEASE DATE:
2013-01-21

DISCUSS ADVISORY:
http://secunia.com/advisories/51842/#comments

AVAILABLE ON SITE AND IN CUSTOMER AREA:
* Last Update
* Popularity
* Comments
* Criticality Level
* Impact
* Where
* Solution Status
* Operating System / Software
* CVE Reference(s)

http://secunia.com/advisories/51842/

ONLY AVAILABLE IN CUSTOMER AREA:
* Authentication Level
* Report Reliability
* Secunia PoC
* Secunia Analysis
* Systems Affected
* Approve Distribution
* Remediation Status
* Secunia CVSS Score
* CVSS

https://ca.secunia.com/?page=viewadvisory&vuln_id=51842

ONLY AVAILABLE WITH SECUNIA CSI AND SECUNIA PSI:
* AUTOMATED SCANNING

http://secunia.com/vulnerability_scanning/personal/
http://secunia.com/vulnerability_scanning/corporate/wsus_sccm_3rd_third_party_patching/

DESCRIPTION:
Multiple weaknesses, two security issues, and multiple
vulnerabilities have been reported in Moodle, where one has an
unknown impact and the others can be exploited by malicious users to
bypass certain security restrictions and by malicious people to
conduct spoofing and cross-site request forgery attacks and disclose
potentially sensitive information.

1) An unspecified error exists in the spellchecker plugin for
TinyMCE. No further information is currently available.

This vulnerability is reported in versions 2.4, 2.3 through 2.3.3+,
2.2 through 2.2.6+, and 2.1 through 2.1.9+.

2) The application does not properly verify capabilities when editing
outcomes, which can be exploited to set outcomes to be a site-wide
standard.

Successful exploitation of this security issue requires teacher
permission.

This security issue is reported in versions 2.4, 2.3 through 2.3.3+,
2.2 through 2.2.6+, 2.1 through 2.1.9+, and 1.9 through 1.9.19.

3) Input passed via the "returnurl" parameter to multiple scripts is
not properly verified before being used to redirect users. This can
be exploited to redirect a user to an arbitrary website e.g. when a
user clicks a specially crafted link to the affected script hosted on
a trusted domain.

List of affected scripts:
http://[host]/backup/backupfilesedit.php
http://[host]/comment/comment_post.php
http://[host]/course/switchrole.php
http://[host]/mod/wiki/filesedit.php
http://[host]/tag/coursetags_add.php
http://[host]/user/files.php

This weakness is reported in versions 2.4, 2.3 through 2.3.3+, and
2.2 to 2.2.6+.

4) The application does not properly restrict access to the feedback
comment viewing functionality, which can be exploited to view
otherwise restricted feedback comments provided on other students'
submissions.

Successful exploitation of this vulnerability requires student
permission.

This vulnerability is reported in versions 2.4 and 2.3 through
2.3.3+.

5) The application allows users to perform certain actions via HTTP
requests without performing proper validity checks to verify the
requests. This can be exploited to e.g. send course messages when a
logged-in user visits a specially crafted web page.

6) The application does not properly restrict access to certain blog
posts, which can be exploited to disclose contents of otherwise
restricted blog posts via related RSS feeds.

The vulnerabilities #5 and #6 are reported in versions 2.4, 2.3
through 2.3.3+, and 2.2 to 2.2.6+.

7) The application does not properly verify capabilities when
handling calendars, which can be exploited to delete a teacher
created course level calendar subscription.

Successful exploitation of this security issue requires student
permission.

This security issue is reported in version 2.4.

SOLUTION:
Update to version 2.4.1, 2.3.4, 2.2.7, 2.1.10, or 1.9.19+ weekly
build (2012-12-20) or later.

Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

PROVIDED AND/OR DISCOVERED BY:
The vendor credits:
1) Petr Skoda
2) Elena Ivanova
3) Simon Coggins
4) Dan Poltawski
5) Andrew Nicols
6) Charles Fulton
7) David O'Brien

ORIGINAL ADVISORY:
Moodle (MSA-13-0001, MSA-13-0002, MSA-13-0005, MSA-13-0006,
MSA-13-0007, MSA-13-0008, MSA-13-0010):
https://moodle.org/mod/forum/discuss.php?d=219612
https://moodle.org/mod/forum/discuss.php?d=220157
https://moodle.org/mod/forum/discuss.php?d=220158
https://moodle.org/mod/forum/discuss.php?d=220162
https://moodle.org/mod/forum/discuss.php?d=220163
https://moodle.org/mod/forum/discuss.php?d=220164
https://moodle.org/mod/forum/discuss.php?d=220165
https://moodle.org/mod/forum/discuss.php?d=220167

OTHER REFERENCES:
Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

DEEP LINKS:
Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

EXTENDED DESCRIPTION:
Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

EXTENDED SOLUTION:
Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

EXPLOIT:
Further details available in Customer Area:
http://secunia.com/vulnerability_intelligence/

----------------------------------------------------------------------

About:
This Advisory was delivered by Secunia as a free service to help
private users keeping their systems up to date against the latest
vulnerabilities.

Subscribe:
http://secunia.com/advisories/secunia_security_advisories/

Definitions: (Criticality, Where etc.)
http://secunia.com/advisories/about_secunia_advisories/


Please Note:
Secunia recommends that you verify all advisories you receive by
clicking the link.
Secunia NEVER sends attached files with advisories.
Secunia does not advise people to install third party patches, only
use those supplied by the vendor.

----------------------------------------------------------------------

Login or Register to add favorites

File Archive:

February 2023

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Feb 1st
    11 Files
  • 2
    Feb 2nd
    9 Files
  • 3
    Feb 3rd
    5 Files
  • 4
    Feb 4th
    0 Files
  • 5
    Feb 5th
    0 Files
  • 6
    Feb 6th
    0 Files
  • 7
    Feb 7th
    0 Files
  • 8
    Feb 8th
    0 Files
  • 9
    Feb 9th
    0 Files
  • 10
    Feb 10th
    0 Files
  • 11
    Feb 11th
    0 Files
  • 12
    Feb 12th
    0 Files
  • 13
    Feb 13th
    0 Files
  • 14
    Feb 14th
    0 Files
  • 15
    Feb 15th
    0 Files
  • 16
    Feb 16th
    0 Files
  • 17
    Feb 17th
    0 Files
  • 18
    Feb 18th
    0 Files
  • 19
    Feb 19th
    0 Files
  • 20
    Feb 20th
    0 Files
  • 21
    Feb 21st
    0 Files
  • 22
    Feb 22nd
    0 Files
  • 23
    Feb 23rd
    0 Files
  • 24
    Feb 24th
    0 Files
  • 25
    Feb 25th
    0 Files
  • 26
    Feb 26th
    0 Files
  • 27
    Feb 27th
    0 Files
  • 28
    Feb 28th
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2022 Packet Storm. All rights reserved.

Hosting By
Rokasec
close