what you don't know can hurt you

Drupal Hostmaster 6.x Cross Site Scripting / Access Bypass

Drupal Hostmaster 6.x Cross Site Scripting / Access Bypass
Posted May 16, 2012
Authored by STE Jones, Ivo Van Geertruyen | Site drupal.org

Drupal Hostmaster third party module version 6.x suffers from access bypass and cross site scripting vulnerabilities.

tags | advisory, vulnerability, xss
MD5 | 6440b605f2d0ee71b456ed2e0f35e92a

Drupal Hostmaster 6.x Cross Site Scripting / Access Bypass

Change Mirror Download
View online: http://drupal.org/node/1585678

* Advisory ID: DRUPAL-SA-CONTRIB-2012-080
* Project: Hostmaster (Aegir) [1] (third-party module)
* Version: 6.x
* Date: 2012-May-16
* Security risk: Less critical [2]
* Exploitable from: Remote
* Vulnerability: Multiple vulnerabilities

-------- DESCRIPTION
---------------------------------------------------------

.... Cross Site Scripting

CVE: Requested.
Hostmaster displays a log from tasks executed in Aegir's backend component,
provision. In certain circumstances these log messages were not escaped
properly before being displayed to the user. This vulnerability is mitigated
by the fact that people wishing to exploit this must have access to the PHP
code of either provision itself or one of the sites hosted by Aegir.

.... Access Bypass

CVE: Requested.
Hostmaster doesn't allow people to edit or create certain node types that are
used for the internal representation of data. The implementation of this
wasn't fully complete and would still allow privileged users to edit these
nodes. This can cause some data corruption in the front-end, leading to tasks
that would appear to never finish running. This vulnerability is mitigated by
the fact that people wishing to exploit this must have the 'edit package' or
'administer nodes' permissions, which are not given to any roles by the
default Aegir install.

-------- VERSIONS AFFECTED
---------------------------------------------------

* Hostmaster 6.x-1.x versions prior to 6.x-1.9.

Drupal core is not affected. If you do not use the contributed Hostmaster
(Aegir) [3] module, there is nothing you need to do.

-------- SOLUTION
------------------------------------------------------------

Follow the upgrade instructions in the release notes for the Aegir 1.9
release which can be found at: http://community.aegirproject.org/1.9 [4]

Also see the Hostmaster (Aegir) [5] project page.

-------- REPORTED BY
---------------------------------------------------------

* The Cross Site Scripting vulnerability was reported by Steven Jones [6]
one of the module maintainers.
* The Access Bypass vulnerability was reported by Ivo Van Geertruyen [7] of
the Drupal Security Team.

-------- FIXED BY
------------------------------------------------------------

* The Cross Site Scripting vulnerability was fixed by Steven Jones [8] one
of the module maintainers.
* The Access Bypass vulnerability was fixed by Ivo Van Geertruyen [9] of the
Drupal Security Team and mig5 [10] one of the module maintainers.

-------- COORDINATED BY
------------------------------------------------------

* Ivo Van Geertruyen [11] of the Drupal Security Team.
* Greg Knaddison [12] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [13].

Learn more about the Drupal Security team and their policies [14], writing
secure code for Drupal [15], and securing your site [16].


[1] http://drupal.org/project/hostmaster
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/hostmaster
[4] http://community.aegirproject.org/1.9
[5] http://drupal.org/project/hostmaster
[6] http://drupal.org/user/99644
[7] http://drupal.org/user/383424
[8] http://drupal.org/user/99644
[9] http://drupal.org/user/383424
[10] http://drupal.org/user/153206
[11] http://drupal.org/user/383424
[12] http://drupal.org/user/36762
[13] http://drupal.org/contact
[14] http://drupal.org/security-team
[15] http://drupal.org/writing-secure-code
[16] http://drupal.org/security/secure-configuration

Comments

RSS Feed Subscribe to this comment feed

No comments yet, be the first!

Login or Register to post a comment

File Archive:

October 2019

  • Su
  • Mo
  • Tu
  • We
  • Th
  • Fr
  • Sa
  • 1
    Oct 1st
    24 Files
  • 2
    Oct 2nd
    15 Files
  • 3
    Oct 3rd
    7 Files
  • 4
    Oct 4th
    4 Files
  • 5
    Oct 5th
    10 Files
  • 6
    Oct 6th
    1 Files
  • 7
    Oct 7th
    21 Files
  • 8
    Oct 8th
    19 Files
  • 9
    Oct 9th
    5 Files
  • 10
    Oct 10th
    20 Files
  • 11
    Oct 11th
    17 Files
  • 12
    Oct 12th
    4 Files
  • 13
    Oct 13th
    4 Files
  • 14
    Oct 14th
    15 Files
  • 15
    Oct 15th
    19 Files
  • 16
    Oct 16th
    25 Files
  • 17
    Oct 17th
    17 Files
  • 18
    Oct 18th
    7 Files
  • 19
    Oct 19th
    1 Files
  • 20
    Oct 20th
    1 Files
  • 21
    Oct 21st
    0 Files
  • 22
    Oct 22nd
    0 Files
  • 23
    Oct 23rd
    0 Files
  • 24
    Oct 24th
    0 Files
  • 25
    Oct 25th
    0 Files
  • 26
    Oct 26th
    0 Files
  • 27
    Oct 27th
    0 Files
  • 28
    Oct 28th
    0 Files
  • 29
    Oct 29th
    0 Files
  • 30
    Oct 30th
    0 Files
  • 31
    Oct 31st
    0 Files

Top Authors In Last 30 Days

File Tags

Systems

packet storm

© 2019 Packet Storm. All rights reserved.

Services
Security Services
Hosting By
Rokasec
close